summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOrhun Parmaksız2022-04-18 20:51:08 +0300
committerOrhun Parmaksız2022-04-18 20:51:08 +0300
commit93b6ecdf9019c4d054429102a557968fc3dad3ab (patch)
treeb22665392e3dfcfed4f68255f3ddd19aa32aa1ef
parentb90edfbfc47e2225d0177da825186d838a16e3a4 (diff)
downloadaur-93b6ecdf9019c4d054429102a557968fc3dad3ab.tar.gz
upgpkg: stegano-git 0.5.1.r0.gcc8c460-1
upstream release
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6a00de4dc93..588e5482e696 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = stegano-git
- pkgdesc = CLI tool for steganography. Supports hiding data in PNG images via LSB Encoding. (git)
- pkgver = 0.5.0.r0.g9f0ee2b
+ pkgdesc = A CLI tool for steganography. Supports hiding data in PNG images via LSB Encoding. (git)
+ pkgver = 0.5.1.r0.gcc8c460
pkgrel = 1
url = https://github.com/steganogram/stegano-rs
arch = x86_64
license = GPL3
- makedepends = rust
+ makedepends = cargo
makedepends = git
depends = bzip2
provides = stegano
conflicts = stegano
+ options = !lto
source = git+https://github.com/steganogram/stegano-rs
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 005bf7f8ff5f..5dedfcbed3c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,19 @@
# https://github.com/orhun/pkgbuilds
pkgname=stegano-git
-pkgver=0.5.0.r0.g9f0ee2b
+pkgver=0.5.1.r0.gcc8c460
pkgrel=1
-pkgdesc="CLI tool for steganography. Supports hiding data in PNG images via LSB Encoding. (git)"
+pkgdesc="A CLI tool for steganography. Supports hiding data in PNG images via LSB Encoding. (git)"
arch=('x86_64')
url="https://github.com/steganogram/stegano-rs"
license=('GPL3')
depends=('bzip2')
-makedepends=('rust' 'git')
+makedepends=('cargo' 'git')
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
source=("git+${url}")
sha512sums=('SKIP')
+options=('!lto')
pkgver() {
cd "${pkgname%-git}-rs"
@@ -22,7 +23,7 @@ pkgver() {
prepare() {
cd "${pkgname%-git}-rs/${pkgname%-git}-cli"
- cargo fetch --locked
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
build() {