summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2020-10-27 10:59:29 -0400
committerGI_Jack2020-10-27 10:59:29 -0400
commitb75e2c256ab96692e04e2ab588d64d66083ac738 (patch)
tree929aaa4d1724cd8b248d90f1b9b0fc74003828f9
downloadaur-b75e2c256ab96692e04e2ab588d64d66083ac738.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD40
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73e2ea0f6044
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = stegbrute
+ pkgdesc = Fast steganography brute force tool written in Rust using also threads to achieve a faster execution
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/R4yGM/stegbrute
+ arch = i686
+ arch = x86_64
+ arch = pentium4
+ license = Apache
+ makedepends = rust
+ depends = steghide
+ source = https://github.com/R4yGM/stegbrute/archive/0.1.1.tar.gz
+ sha256sums = 99e7d09926caaa99d4dde2dff73c24e2882931f80611d8ddc210b3afdb26aa5c
+
+pkgname = stegbrute
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac6796904f2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: GI_Jack <GI_Jack@hackermail.com>
+
+pkgname=stegbrute
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Fast steganography brute force tool written in Rust using also threads to achieve a faster execution"
+arch=('i686' 'x86_64' 'pentium4')
+url="https://github.com/R4yGM/stegbrute"
+license=('Apache')
+groups=()
+depends=('steghide')
+makedepends=('rust')
+checkdepends=()
+optdepends=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/R4yGM/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('99e7d09926caaa99d4dde2dff73c24e2882931f80611d8ddc210b3afdb26aa5c')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ sed -i 's/version = "0.1.0"/version = "0.1.1"/' Cargo.lock
+}
+
+#check() {
+# cd "${pkgname}-${pkgver}"
+# cargo test --release --locked --target-dir=target
+#}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ return 0
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ cargo install --no-track --locked --all-features --root "${pkgdir}/usr/" --path .
+}