summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-05-01 19:40:25 +0000
committerAntonio Rojas2020-05-01 19:40:25 +0000
commit94e67ce9f96c5760971c66c80502c30ae220bcc2 (patch)
tree572e7eb25e590ea61be7a663ef87f3d17fd73b7b
downloadaur-94e67ce9f96c5760971c66c80502c30ae220bcc2.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO25
-rw-r--r--ChangeLog4
-rw-r--r--PKGBUILD47
-rw-r--r--buildsystem.patch10
-rw-r--r--gcc-4.2.patch75
-rw-r--r--steghide-climits.patch11
-rw-r--r--steghide-gcc6.patch22
7 files changed, 194 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b88800e96f25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = steghide
+ pkgdesc = Embeds a message in a file by replacing some of the least significant bits
+ pkgver = 0.5.1
+ pkgrel = 9
+ url = http://steghide.sourceforge.net
+ arch = x86_64
+ license = GPL
+ depends = libmcrypt
+ depends = gcc-libs
+ depends = mhash
+ depends = libjpeg
+ depends = zlib
+ source = https://downloads.sourceforge.net/steghide/steghide-0.5.1.tar.gz
+ source = buildsystem.patch
+ source = gcc-4.2.patch
+ source = steghide-climits.patch
+ source = steghide-gcc6.patch
+ md5sums = 5be490e24807d921045780fd8cc446b3
+ md5sums = 14f5e054d71c91262bb1140288043df8
+ md5sums = fd861dc5a0a392c6c94a61e85ad74f29
+ md5sums = 897ce18edd008293a3328bc3f88775b3
+ md5sums = 6dd60a84fccca270fa7315f1102454ff
+
+pkgname = steghide
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..4cdd510bf063
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,4 @@
+2007-06-28 tardo <tardo@nagi-fanboi.net>
+* Built for x86_64
+* Added gcc 4.2 patch, with help from gentoo bug #178134
+* Fixed erroneous buildsystem.patch that removed path to mkinstalldirs
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7df659d5bdfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Contributor: Jason Chu <jason@archlinux.org>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgname=steghide
+pkgver=0.5.1
+pkgrel=9
+pkgdesc='Embeds a message in a file by replacing some of the least significant bits'
+arch=('x86_64')
+url='http://steghide.sourceforge.net'
+license=('GPL')
+depends=('libmcrypt' 'gcc-libs' 'mhash' 'libjpeg' 'zlib')
+source=("https://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ 'buildsystem.patch'
+ 'gcc-4.2.patch'
+ "${pkgname}-climits.patch"
+ steghide-gcc6.patch)
+md5sums=('5be490e24807d921045780fd8cc446b3'
+ '14f5e054d71c91262bb1140288043df8'
+ 'fd861dc5a0a392c6c94a61e85ad74f29'
+ '897ce18edd008293a3328bc3f88775b3'
+ '6dd60a84fccca270fa7315f1102454ff')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ patch -p1 < ../buildsystem.patch
+
+ # this patch courtesy gentoo bug tracker #178134
+ patch -Np1 -i ../gcc-4.2.patch
+ patch -Np1 -i ../steghide-climits.patch
+
+ patch -p1 -i ../steghide-gcc6.patch # Fix build with GCC 6
+
+ # touch files needed by GNU Autotools
+ touch NEWS AUTHORS ChangeLog
+
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/buildsystem.patch b/buildsystem.patch
new file mode 100644
index 000000000000..e1fc057f73a2
--- /dev/null
+++ b/buildsystem.patch
@@ -0,0 +1,10 @@
+diff -urN steghide-0.5.1/src/Makefile.am steghide-0.5.1-new/src/Makefile.am
+--- steghide-0.5.1/src/Makefile.am 2003-09-28 09:33:21.000000000 -0700
++++ steghide-0.5.1-new/src/Makefile.am 2003-10-30 21:05:40.000000000 -0800
+@@ -33,5 +33,5 @@
+ WavPCMSampleValue.cc error.cc main.cc msg.cc SMDConstructionHeuristic.cc
+ LIBS = @LIBINTL@ @LIBS@
+ localedir = $(datadir)/locale
+-LIBTOOL = $(SHELL) libtool
++LIBTOOL = /usr/bin/libtool
+ MAINTAINERCLEANFILES = Makefile.in
diff --git a/gcc-4.2.patch b/gcc-4.2.patch
new file mode 100644
index 000000000000..36848dd4c046
--- /dev/null
+++ b/gcc-4.2.patch
@@ -0,0 +1,75 @@
+diff -Naur steghide-0.5.1.orig/src/AuData.h steghide-0.5.1.new/src/AuData.h
+--- steghide-0.5.1.orig/src/AuData.h 2003-09-28 11:30:29.000000000 -0400
++++ steghide-0.5.1.new/src/AuData.h 2007-06-28 17:22:44.000000000 -0400
+@@ -26,22 +26,30 @@
+
+ // AuMuLawAudioData
+ typedef AudioDataImpl<AuMuLaw,BYTE> AuMuLawAudioData ;
++template<>
+ inline BYTE AuMuLawAudioData::readValue (BinaryIO* io) const { return (io->read8()) ; }
++template<>
+ inline void AuMuLawAudioData::writeValue (BinaryIO* io, BYTE v) const { io->write8(v) ; }
+
+ // AuPCM8AudioData
+ typedef AudioDataImpl<AuPCM8,SBYTE> AuPCM8AudioData ;
++template<>
+ inline SBYTE AuPCM8AudioData::readValue (BinaryIO* io) const { return ((SBYTE) io->read8()) ; }
++template<>
+ inline void AuPCM8AudioData::writeValue (BinaryIO* io, SBYTE v) const { io->write8((BYTE) v) ; }
+
+ // AuPCM16AudioData
+ typedef AudioDataImpl<AuPCM16,SWORD16> AuPCM16AudioData ;
++template<>
+ inline SWORD16 AuPCM16AudioData::readValue (BinaryIO* io) const { return ((SWORD16) io->read16_be()) ; }
++template<>
+ inline void AuPCM16AudioData::writeValue (BinaryIO* io, SWORD16 v) const { io->write16_be((UWORD16) v) ; }
+
+ // AuPCM32AudioData
+ typedef AudioDataImpl<AuPCM32,SWORD32> AuPCM32AudioData ;
++template<>
+ inline SWORD32 AuPCM32AudioData::readValue (BinaryIO* io) const { return ((SWORD32) io->read32_be()) ; }
++template<>
+ inline void AuPCM32AudioData::writeValue (BinaryIO* io, SWORD32 v) const { io->write32_be((UWORD32) v) ; }
+
+ #endif // ndef SH_AUDATA_H
+diff -Naur steghide-0.5.1.orig/src/AuSampleValues.cc steghide-0.5.1.new/src/AuSampleValues.cc
+--- steghide-0.5.1.orig/src/AuSampleValues.cc 2003-09-28 11:30:30.000000000 -0400
++++ steghide-0.5.1.new/src/AuSampleValues.cc 2007-06-28 17:23:52.000000000 -0400
+@@ -21,17 +21,25 @@
+ #include "AuSampleValues.h"
+
+ // AuMuLawSampleValue
++template<>
+ const BYTE AuMuLawSampleValue::MinValue = 0 ;
++template<>
+ const BYTE AuMuLawSampleValue::MaxValue = BYTE_MAX ;
+
+ // AuPCM8SampleValue
++template<>
+ const SBYTE AuPCM8SampleValue::MinValue = SBYTE_MIN ;
++template<>
+ const SBYTE AuPCM8SampleValue::MaxValue = SBYTE_MAX ;
+
+ // AuPCM16SampleValue
++template<>
+ const SWORD16 AuPCM16SampleValue::MinValue = SWORD16_MIN ;
++template<>
+ const SWORD16 AuPCM16SampleValue::MaxValue = SWORD16_MAX ;
+
+ // AuPCM32SampleValue
++template<>
+ const SWORD32 AuPCM32SampleValue::MinValue = SWORD32_MIN ;
++template<>
+ const SWORD32 AuPCM32SampleValue::MaxValue = SWORD32_MAX ;
+diff -Naur steghide-0.5.1.orig/src/MHashPP.cc steghide-0.5.1.new/src/MHashPP.cc
+--- steghide-0.5.1.orig/src/MHashPP.cc 2003-10-05 06:17:50.000000000 -0400
++++ steghide-0.5.1.new/src/MHashPP.cc 2007-06-28 17:22:44.000000000 -0400
+@@ -120,7 +120,7 @@
+
+ std::string MHashPP::getAlgorithmName (hashid id)
+ {
+- char *name = mhash_get_hash_name (id) ;
++ char *name = (char *) mhash_get_hash_name (id) ;
+ std::string retval ;
+ if (name == NULL) {
+ retval = std::string ("<algorithm not found>") ;
diff --git a/steghide-climits.patch b/steghide-climits.patch
new file mode 100644
index 000000000000..a7e54f51c193
--- /dev/null
+++ b/steghide-climits.patch
@@ -0,0 +1,11 @@
+diff -ruN steghide-0.5.1.orig/src/Graph.cc steghide-0.5.1/src/Graph.cc
+--- steghide-0.5.1.orig/src/Graph.cc 2003-10-11 23:54:26.000000000 +0200
++++ steghide-0.5.1/src/Graph.cc 2008-12-14 14:23:27.000000000 +0100
+@@ -22,6 +22,7 @@
+ #include <list>
+ #include <map>
+ #include <vector>
++#include <climits>
+
+ #include "BitString.h"
+ #include "CvrStgFile.h"
diff --git a/steghide-gcc6.patch b/steghide-gcc6.patch
new file mode 100644
index 000000000000..a3a3067912c8
--- /dev/null
+++ b/steghide-gcc6.patch
@@ -0,0 +1,22 @@
+--- steghide-0.5.1/src/Arguments.h.orig 2018-06-09 11:04:48.795952519 +0000
++++ steghide-0.5.1/src/Arguments.h 2018-06-09 11:00:57.239290249 +0000
+@@ -100,7 +100,7 @@
+ static const VERBOSITY Default_Verbosity = NORMAL ;
+ static const unsigned long Default_Radius = 0 ; // there is no default radius for all file formats
+ static const unsigned int Max_Algorithm = 3 ;
+- static const float Default_Goal = 100.0 ;
++ static constexpr float Default_Goal = 100.0 ;
+ static const DEBUGCOMMAND Default_DebugCommand = NONE ;
+ static const bool Default_Check = false ;
+ static const unsigned int Default_DebugLevel = 0 ;
+--- steghide-0.5.1/src/ProgressOutput.h.orig 2018-06-09 11:01:44.662622682 +0000
++++ steghide-0.5.1/src/ProgressOutput.h 2018-06-09 11:01:57.755955767 +0000
+@@ -64,7 +64,7 @@
+ **/
+ void done (float rate, float avgweight = NoAvgWeight) const ;
+
+- static const float NoAvgWeight = -1.0 ;
++ static constexpr float NoAvgWeight = -1.0 ;
+
+ protected:
+ std::string vcompose (const char *msgfmt, va_list ap) const ;