summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2020-03-06 10:40:44 +0100
committerSefa Eyeoglu2020-03-06 10:40:44 +0100
commit39749eeaecfd7ad8b8556e8fb524a9860109d8f0 (patch)
treee3879307381183e57a974427a10684108beb8d37
parentbe16f9aed5bc58debe4b3165791bc8d5fd27001e (diff)
downloadaur-39749eeaecfd7ad8b8556e8fb524a9860109d8f0.tar.gz
Initial commit VCS package
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db7f4aeda84c..f2fb835b3ad5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = stegify
+pkgbase = stegify-git
pkgdesc = Tool for LSB steganography written in Go
- pkgver = 1.2
+ pkgver = 1.2.r1.gde74f17
pkgrel = 1
url = https://github.com/DimitarPetrov/stegify
arch = x86_64
@@ -9,8 +9,8 @@ pkgbase = stegify
makedepends = go-pie
makedepends = golang-golang-x-tools
depends = glibc
- source = stegify::git+https://github.com/DimitarPetrov/stegify.git#tag=v1.2
+ source = stegify::git+https://github.com/DimitarPetrov/stegify.git
sha512sums = SKIP
-pkgname = stegify
+pkgname = stegify-git
diff --git a/PKGBUILD b/PKGBUILD
index 2acc925701bc..1a82f28d0f07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
_pkgname=stegify
-pkgname=${_pkgname}
-pkgver=1.2
+pkgname=${_pkgname}-git
+pkgver=1.2.r1.gde74f17
pkgrel=1
pkgdesc="Tool for LSB steganography written in Go"
arch=(x86_64)
@@ -10,10 +10,16 @@ url="https://github.com/DimitarPetrov/stegify"
license=("custom:MIT")
depends=("glibc")
makedepends=("git" "go-pie" "golang-golang-x-tools")
-source=("${_pkgname}::git+https://github.com/DimitarPetrov/stegify.git#tag=v${pkgver}")
+source=("${_pkgname}::git+https://github.com/DimitarPetrov/stegify.git")
sha512sums=('SKIP')
+pkgver() {
+ cd "$_pkgname"
+
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | cut -c2-
+}
+
prepare() {
cd "$_pkgname"