summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Karmanov2023-07-14 14:04:00 +0300
committerAnton Karmanov2023-07-14 14:04:00 +0300
commit26542d787b31d21d21263c4b706cd37e9888f752 (patch)
treeedf299ecd477418aba674e6d5e50a4d0658a53fe
parent454e324fed5ba4b474ded1074202341577dffd5f (diff)
downloadaur-26542d787b31d21d21263c4b706cd37e9888f752.tar.gz
Update to v0.4.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c2ebb5da81e..80b4a6a473b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = stegosaurus-lv2
pkgdesc = lv2 drum synthersizer without sampling
- pkgver = 0.0.3
- pkgrel = 3
+ pkgver = 0.4.0
+ pkgrel = 1
url = https://sourceforge.net/projects/stegosaurus-lv2
arch = i686
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = stegosaurus-lv2
makedepends = python2
depends = lv2
depends = cairo
- source = https://sourceforge.net/projects/stegosaurus-lv2/files/Stegosaurus_LV2_0.0.3.tar.gz
- md5sums = fec688cf4eced6e0ade69ce4d8cd33cd
+ source = https://sourceforge.net/projects/stegosaurus-lv2/files/stegosaurus_v0.4.0_October_2021.tar.gz
+ md5sums = 6c67794431aedfefd44e3aca21c862dd
pkgname = stegosaurus-lv2
diff --git a/PKGBUILD b/PKGBUILD
index 5d42b0be7a0d..ebc5ee9d6414 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,32 @@
-# Maintainer: Anton Karmanov <starcom24@gmail.com>
+# Maintainer: Anton Karmanov <a.karmanov@inventati.org>
pkgname=stegosaurus-lv2
-pkgver=0.0.3
-pkgrel=3
+pkgver=0.4.0
+pkgrel=1
pkgdesc="lv2 drum synthersizer without sampling"
arch=('i686' 'x86_64')
url="https://sourceforge.net/projects/$pkgname"
license=('BSD')
depends=('lv2' 'cairo')
makedepends=('python-virtualenv' 'python2')
-source=("https://sourceforge.net/projects/$pkgname/files/Stegosaurus_LV2_${pkgver}.tar.gz")
-md5sums=('fec688cf4eced6e0ade69ce4d8cd33cd')
+source=("https://sourceforge.net/projects/$pkgname/files/stegosaurus_v0.4.0_October_2021.tar.gz")
+md5sums=('6c67794431aedfefd44e3aca21c862dd')
prepare() {
- cd "stegosaurus-git"
+ cd stegosaurus
virtualenv -p python2 python2_env
source python2_env/bin/activate
python -V
}
build() {
+ cd stegosaurus
LDFLAGS="${LDFLAGS} -z muldefs" # Ignore multiple defenitions
- cd "stegosaurus-git"
- ./waf configure --prefix=$pkgdir/usr
+ LV2_PATH="${HOME}./lv2/:/usr/local/lib/lv2/:/usr/lib/lv2/"
+ env LV2_PATH="$LV2_PATH" ./waf configure --prefix="${pkgdir}/usr"
./waf build
}
package() {
- cd "stegosaurus-git"
- ./waf install
+ cd stegosaurus
+ ./waf --destdir="$pkgdir" install
}