summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Mazieres2020-07-22 23:25:02 -0700
committerDavid Mazieres2020-07-22 23:25:02 -0700
commit4799130bfb77c5895925c67f101c66f29e5a3234 (patch)
tree216f28fdf997edfd0874ff21530c9db65ea201d7
parent96ac04179106e3ea955e00c8e5edafacd936bf46 (diff)
downloadaur-stellar-core-git.tar.gz
include new git submodules
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD12
2 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ab39e1e78d6..5df4b1b9f1cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
-# Generated by mksrcinfo v8
-# Thu Mar 3 18:27:06 UTC 2016
pkgbase = stellar-core-git
- pkgdesc = core daemon for backbone nodes in the payment Stellar network
- pkgver = v0.4.1.61.gffd1ccd
+ pkgdesc = core daemon for full nodes in the Stellar payment network
+ pkgver = v13.2.0.67.g670982dc
pkgrel = 1
url = https://www.stellar.org/
arch = x86_64
arch = i686
license = APACHE
makedepends = git
+ makedepends = parallel
depends = postgresql
provides = stellar-core
conflicts = stellar-core
@@ -16,6 +15,14 @@ pkgbase = stellar-core-git
source = libmedida::git+https://github.com/stellar/medida.git
source = git+https://github.com/stellar/libsodium.git
source = git+https://github.com/xdrpp/xdrpp.git
+ source = git+https://github.com/USCiLab/cereal
+ source = git+https://github.com/chriskohlhoff/asio.git
+ source = git+https://github.com/fmtlib/fmt
+ source = git+https://github.com/stellar/tracy
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 143399c9c7da..ddf351f3c0c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: David Mazieres (http://www.scs.stanford.edu/~dm/addr/)
pkgname=stellar-core-git
-pkgver=v9.2.0.97.ga3c0cf61
+pkgver=v13.2.0.67.g670982dc
pkgrel=1
-pkgdesc="core daemon for backbone nodes in the payment Stellar network"
+pkgdesc="core daemon for full nodes in the Stellar payment network"
arch=(x86_64 i686)
url="https://www.stellar.org/"
license=('APACHE')
depends=(postgresql)
-makedepends=('git')
+makedepends=('git' 'parallel')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
install=
@@ -18,9 +18,11 @@ source=('git+https://github.com/stellar/stellar-core.git'
'git+https://github.com/xdrpp/xdrpp.git'
'git+https://github.com/USCiLab/cereal'
'git+https://github.com/chriskohlhoff/asio.git'
+ 'git+https://github.com/fmtlib/fmt'
+ 'git+https://github.com/stellar/tracy'
)
noextract=()
-md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -38,11 +40,11 @@ prepare() {
done
./autogen.sh
+ ./configure --prefix=/usr
}
build() {
cd "$srcdir/${pkgname%-git}"
- ./configure --prefix=/usr
make
}