summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmytro Bagrii2023-09-26 08:16:20 +0300
committerDmytro Bagrii2023-09-26 08:16:20 +0300
commit5860bebd959ae46869a3f55200cabc369b4ce688 (patch)
tree287e5b5b1a813be6f72256eb4200e07d67623038
parent7d7f9e8f9e3dff6c0bc58e934dc50b0da2403936 (diff)
downloadaur-5860bebd959ae46869a3f55200cabc369b4ce688.tar.gz
Bump version to 23.3
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD25
2 files changed, 21 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ffab6017f68..7cc6005601cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = stellarium-lite
pkgdesc = Stellarium without GPS and Telescope Control support (no gpsd and libindi dependencies)
- pkgver = 23.2
+ pkgver = 23.3
pkgrel = 1
url = https://stellarium.org
arch = x86_64
@@ -17,13 +17,14 @@ pkgbase = stellarium-lite
depends = qt6-charts
depends = qt6-multimedia
depends = qt6-webengine
+ optdepends = man-db: manual pages for stellarium
conflicts = stellarium
- source = https://github.com/Stellarium/stellarium/releases/download/v23.2/stellarium-23.2.tar.gz
- source = https://github.com/Stellarium/stellarium/releases/download/v23.2/stellarium-23.2.tar.gz.asc
+ source = https://github.com/Stellarium/stellarium/releases/download/v23.3/stellarium-23.3.tar.gz
+ source = https://github.com/Stellarium/stellarium/releases/download/v23.3/stellarium-23.3.tar.gz.asc
validpgpkeys = 79151C2E6351E7278DA1A730BF38D4D02A328DFF
- md5sums = b42a829ffe080ba7c27b8ff25ba8a9c8
+ md5sums = 04bcc9996f73f9861700126eba1645ce
md5sums = SKIP
- sha256sums = 01bf23f7ff007c58b91bffe233938e2cf23e9182bd36bfe72715fbfbde57ec0a
+ sha256sums = 55afd3bd44de76c156dadb17d52023ed5d4a74297dcff3c98eb71adef0fd66d9
sha256sums = SKIP
pkgname = stellarium-lite
diff --git a/PKGBUILD b/PKGBUILD
index 3192bca2c5c0..b20431da59f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname=stellarium
pkgname=${_pkgname}-lite
-pkgver=23.2
+pkgver=23.3
pkgrel=1
pkgdesc="Stellarium without GPS and Telescope Control support (no gpsd and libindi dependencies)"
arch=(x86_64)
@@ -15,18 +15,22 @@ license=(GPL2)
depends=('libpng' 'libglvnd' 'freetype2' 'openssl' 'calcmysky>=0.3'
'qt6-charts' 'qt6-multimedia' 'qt6-webengine') # 'qxlsx'
makedepends=('cmake' 'ninja' 'mesa' 'qt6-tools')
+optdepends=('man-db: manual pages for stellarium')
conflicts=(${_pkgname})
source=(https://github.com/Stellarium/${_pkgname}/releases/download/v${pkgver}/${_pkgname}-${pkgver}.tar.gz{,.asc})
validpgpkeys=('79151C2E6351E7278DA1A730BF38D4D02A328DFF') # Alexander Wolf <alex.v.wolf@gmail.com>
-md5sums=('b42a829ffe080ba7c27b8ff25ba8a9c8'
+md5sums=('04bcc9996f73f9861700126eba1645ce'
'SKIP')
-sha256sums=('01bf23f7ff007c58b91bffe233938e2cf23e9182bd36bfe72715fbfbde57ec0a'
+sha256sums=('55afd3bd44de76c156dadb17d52023ed5d4a74297dcff3c98eb71adef0fd66d9'
'SKIP')
-# prepare() {
-# # https://github.com/Stellarium/stellarium/issues/3132#issuecomment-1485304021
-# sed -i 's/SOURCE_SUBDIR QXlsx/SOURCE_SUBDIR QXlsxQt${QT_VERSION_MAJOR}/' ${pkgname}-${pkgver}/CMakeLists.txt
-# }
+#prepare() {
+# # FIXME: https://github.com/Stellarium/stellarium/issues/3132#issuecomment-1485304021
+# # sed -i 's/SOURCE_SUBDIR QXlsx/SOURCE_SUBDIR QXlsxQt${QT_VERSION_MAJOR}/' ${pkgname}-${pkgver}/CMakeLists.txt
+# # TODO: https://github.com/Stellarium/stellarium/issues/3038
+# cd ${pkgname}-${pkgver}
+# patch -p1 -i ../indi-2.0.patch
+#}
build() {
PATH="/usr/bin/core_perl/:$PATH"
@@ -38,10 +42,10 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_C_COMPILER=gcc \
-DCMAKE_CXX_STANDARD=17 \
- -DCMAKE_C_EXTENSIONS=No \
+ -DCMAKE_C_EXTENSIONS=Yes \
-DCMAKE_CXX_COMPILER=g++ \
- -DCMAKE_C_STANDARD=11 \
- -DCMAKE_CXX_EXTENSIONS=No \
+ -DCMAKE_C_STANDARD=17 \
+ -DCMAKE_CXX_EXTENSIONS=Yes \
-DENABLE_QT6=1 \
-DENABLE_SHOWMYSKY=ON \
-DENABLE_TESTING=0 \
@@ -56,5 +60,6 @@ build() {
package() {
DESTDIR="${pkgdir}" cmake --build build --target install
+ install -Dm 644 ${_pkgname}-${pkgver}/COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
find "${pkgdir}" -type d -empty -delete
}