summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmytro Bagrii2023-06-03 01:06:04 +0300
committerDmytro Bagrii2023-06-03 01:07:19 +0300
commit5da1b39d1b5a1a610e455f65371963924f382b58 (patch)
treefc381130a1f71df3ec4457421446fd9136813947
parent52561af99db4938d8cffc368dec01b3c35b459d0 (diff)
downloadaur-5da1b39d1b5a1a610e455f65371963924f382b58.tar.gz
Bump version to 23.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbf9a19c401d..53f9d9251785 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = stellarium-lite
pkgdesc = Stellarium without GPS and Telescope Control support (no gpsd and libindi dependencies)
- pkgver = 1.2
+ pkgver = 23.1
pkgrel = 1
url = https://stellarium.org
arch = x86_64
@@ -18,12 +18,12 @@ pkgbase = stellarium-lite
depends = qt6-multimedia
depends = qt6-webengine
conflicts = stellarium
- source = https://github.com/Stellarium/stellarium/releases/download/v1.2/stellarium-1.2.tar.gz
- source = https://github.com/Stellarium/stellarium/releases/download/v1.2/stellarium-1.2.tar.gz.asc
+ source = https://github.com/Stellarium/stellarium/releases/download/v23.1/stellarium-23.1.tar.gz
+ source = https://github.com/Stellarium/stellarium/releases/download/v23.1/stellarium-23.1.tar.gz.asc
validpgpkeys = 79151C2E6351E7278DA1A730BF38D4D02A328DFF
- md5sums = 1a9b2b69300ac54fda47cf4b801bf07f
+ md5sums = 7dde5f42e434fff6aa622cd239385709
md5sums = SKIP
- sha256sums = 2cbf95839c5fbd312c08ad0f92b2ddf8a7f822bd32bc31e91f3aa28920674f60
+ sha256sums = c0d519ef44e78c0609b576c068e1ef2ad09e635d4ff73de7d41bb8c7323bad27
sha256sums = SKIP
pkgname = stellarium-lite
diff --git a/PKGBUILD b/PKGBUILD
index 3704c519fd3b..2b7384ee9502 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname=stellarium
pkgname=${_pkgname}-lite
-pkgver=1.2
+pkgver=23.1
pkgrel=1
pkgdesc="Stellarium without GPS and Telescope Control support (no gpsd and libindi dependencies)"
arch=(x86_64)
@@ -18,10 +18,15 @@ makedepends=('cmake' 'ninja' 'mesa' 'qt6-tools')
conflicts=(${_pkgname})
source=(https://github.com/Stellarium/${_pkgname}/releases/download/v${pkgver}/${_pkgname}-${pkgver}.tar.gz{,.asc})
validpgpkeys=('79151C2E6351E7278DA1A730BF38D4D02A328DFF') # Alexander Wolf <alex.v.wolf@gmail.com>
-md5sums=('1a9b2b69300ac54fda47cf4b801bf07f'
- 'SKIP')
-sha256sums=('2cbf95839c5fbd312c08ad0f92b2ddf8a7f822bd32bc31e91f3aa28920674f60'
- 'SKIP')
+md5sums=('7dde5f42e434fff6aa622cd239385709'
+ 'SKIP')
+sha256sums=('c0d519ef44e78c0609b576c068e1ef2ad09e635d4ff73de7d41bb8c7323bad27'
+ 'SKIP')
+
+# prepare() {
+# # https://github.com/Stellarium/stellarium/issues/3132#issuecomment-1485304021
+# sed -i 's/SOURCE_SUBDIR QXlsx/SOURCE_SUBDIR QXlsxQt${QT_VERSION_MAJOR}/' ${pkgname}-${pkgver}/CMakeLists.txt
+# }
build() {
PATH="/usr/bin/core_perl/:$PATH"
@@ -44,6 +49,7 @@ build() {
-DENABLE_GPS=0 \
-DENABLE_LIBGPS=0 \
-DUSE_PLUGIN_TELESCOPECONTROL=0 \
+ -DPREFER_SYSTEM_INDILIB=No \
-Wno-dev
cmake --build build --target all
}