summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDustin Wilhoit2022-01-19 21:50:09 -0600
committerDustin Wilhoit2022-01-19 21:50:09 -0600
commit42c6937ca4e2277444db4f16ebadb4cf9c805812 (patch)
treea0b3c1b275f1711b357e8dc6c8a8c5b2cbf41902
parent1cc3675625f3643168b5b3382695099ae0a9925c (diff)
downloadaur-42c6937ca4e2277444db4f16ebadb4cf9c805812.tar.gz
Taking ownership and updating to 1.0.8-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
-rw-r--r--include-unistd-h.patch10
3 files changed, 8 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db65848ebe23..080dfb860bdd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,12 @@
-# Generated by mksrcinfo v8
-# Wed Oct 3 04:33:16 UTC 2018
pkgbase = stenc
pkgdesc = SCSI Tape Encryption Manager
- pkgver = 1.0.7
+ pkgver = 1.0.8
pkgrel = 1
url = http://stenc.sourceforge.net/
arch = i686
arch = x86_64
license = GPLv2
- source = https://github.com/scsitape/stenc/archive/1.0.7.tar.gz
- md5sums = 3783cd4e23076b6330e2645b5114e946
+ source = https://github.com/scsitape/stenc/archive/1.0.8.tar.gz
+ sha512sums = 4fd882861d248cf59cde1782833bd3e4f7e01e8b6c00424c55f26454a620510b22de0d42f2d7f6c4e67c2b277776a174fe687756a75f410026fda55554f9dc87
pkgname = stenc
-
diff --git a/PKGBUILD b/PKGBUILD
index 733537a0b096..678c810190c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,20 @@
-# Maintainer: Phillip Smith <pkgbuild@phs.id.au>
-# http://github.com/fukawi2/aur-packages
-
-### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
-### Please ask support questions about this software in one of:
-### 1) The AUR comments; OR
-### 2) Upstream forums/maillist etc; OR
-### 3) The ArchLinux forums
-### I do not always know enough about the software itself, or don't have the
-### time to promptly respond to direct emails.
-### If you have found a problem with the package/PKGBUILD (as opposed to
-### the software) then please do email me or post an AUR comment.
+# Maintainer: Dustin Wilhoit <dustin@wilhoitclan.com>
+# Original Maintainer: Phillip Smith <pkgbuild@phs.id.au> - http://github.com/fukawi2/aur-packages
pkgname=stenc
-pkgver=1.0.7
+pkgver=1.0.8
pkgrel=1
pkgdesc="SCSI Tape Encryption Manager"
arch=('i686' 'x86_64')
license=('GPLv2')
url="http://stenc.sourceforge.net/"
source=("https://github.com/scsitape/${pkgname}/archive/${pkgver}.tar.gz")
-md5sums=('3783cd4e23076b6330e2645b5114e946')
+sha512sums=('4fd882861d248cf59cde1782833bd3e4f7e01e8b6c00424c55f26454a620510b22de0d42f2d7f6c4e67c2b277776a174fe687756a75f410026fda55554f9dc87')
build() {
cd "$srcdir"/$pkgname-$pkgver
- # configure
+ autoreconf --install
./configure \
--prefix=/usr \
--sysconfdir=/etc
diff --git a/include-unistd-h.patch b/include-unistd-h.patch
deleted file mode 100644
index de6d51a75f15..000000000000
--- a/include-unistd-h.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/scsiencrypt.cpp.ORIG 2013-12-20 11:55:29.440418158 +1100
-+++ src/scsiencrypt.cpp 2013-12-20 11:55:36.100105387 +1100
-@@ -21,6 +21,7 @@
- #include <fcntl.h>
- #include <errno.h>
- #include <sys/ioctl.h>
-+#include <unistd.h>
-
- #ifdef OS_AIX //AIX
- #define _LINUX_SOURCE_COMPAT