summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillip Smith2015-06-02 12:20:26 +1000
committerPhillip Smith2015-06-02 12:20:26 +1000
commit64637cbae6779ee9d68af4284239ed3d34d6006c (patch)
treef9de34946cfb6f97d505c41c94bc6230eb7dad94
downloadaur-64637cbae6779ee9d68af4284239ed3d34d6006c.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
-rw-r--r--include-unistd-h.patch10
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1219e9606c65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = stenc
+ pkgdesc = SCSI Tape Encryption Manager
+ pkgver = 1.0.6
+ pkgrel = 1
+ url = http://stenc.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPLv2
+ source = http://downloads.sourceforge.net/stenc/stenc-1.0.6.tar.gz
+ source = include-unistd-h.patch
+ md5sums = 310664c64cf3f9a1007367072bccb5b8
+ md5sums = f58feb684189a14afda06859337181f3
+
+pkgname = stenc
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..002ba7b9dc34
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/stenc-*.pkg.tar.xz
+/stenc-*.tar.gz
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..237dfd13fb17
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
+# http://github.com/fukawi2/aur-packages
+
+### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
+### Please ask support questions about this software in one of:
+### 1) The AUR comments; OR
+### 2) Upstream forums/maillist etc; OR
+### 3) The ArchLinux forums
+### I do not always know enough about the software itself, or don't have the
+### time to promptly respond to direct emails.
+### If you have found a problem with the package/PKGBUILD (as opposed to
+### the software) then please do email me or post an AUR comment.
+
+pkgname=stenc
+pkgver=1.0.6
+pkgrel=1
+pkgdesc="SCSI Tape Encryption Manager"
+arch=('i686' 'x86_64')
+license=('GPLv2')
+url="http://stenc.sourceforge.net/"
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ 'include-unistd-h.patch')
+md5sums=('310664c64cf3f9a1007367072bccb5b8'
+ 'f58feb684189a14afda06859337181f3')
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ patch -p0 < "$srcdir"/include-unistd-h.patch
+
+ # configure
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc
+
+ # build
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/include-unistd-h.patch b/include-unistd-h.patch
new file mode 100644
index 000000000000..de6d51a75f15
--- /dev/null
+++ b/include-unistd-h.patch
@@ -0,0 +1,10 @@
+--- src/scsiencrypt.cpp.ORIG 2013-12-20 11:55:29.440418158 +1100
++++ src/scsiencrypt.cpp 2013-12-20 11:55:36.100105387 +1100
+@@ -21,6 +21,7 @@
+ #include <fcntl.h>
+ #include <errno.h>
+ #include <sys/ioctl.h>
++#include <unistd.h>
+
+ #ifdef OS_AIX //AIX
+ #define _LINUX_SOURCE_COMPAT