summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSander Smid-Merlijn2019-07-12 21:06:04 +0200
committerSander Smid-Merlijn2019-07-12 21:06:04 +0200
commitd7bdc787b0f7115f09002a19e5169628987eb56d (patch)
tree9881e4a458aaefa78e8ce73333243e546c38bdd7
parenta43b487370a7a8451f18cb8385ce898ce3152a8d (diff)
downloadaur-d7bdc787b0f7115f09002a19e5169628987eb56d.tar.gz
Updated to 4.0.1. This version removes support the 32bit versions of Stencyl (might still work but upstream only provides lin64 downloads).
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
2 files changed, 14 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5eb05a80612..2e2d10af45b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = stencyl
pkgdesc = Create amazing games without code
- pkgver = 3.4.0
- pkgrel = 2
+ pkgver = 4.0.1
+ pkgrel = 1
url = http://www.stencyl.com
- arch = i686
arch = x86_64
license = custom
- noextract = stencyl.tar.gz
options = !strip
source = stencyl
source = stencyl.desktop
source = stencyl.png
source = LICENSE
+ source = Stencyl-64-full.tar.gz::http://www.stencyl.com/download/get/lin64/
md5sums = e97ff31637ae4f223062269bfce3f8ab
- md5sums = 6b52a9ecce3bddda2e77b3884503b888
+ md5sums = 97eccf2c15f9f40bac4aaebbfe06f976
md5sums = c99ae55db267e86c0936e01662ee12ea
md5sums = 986e231db4a39dd7fa59c93a7e06b7c2
+ md5sums = 3c1691239496ca02be97bb9fcd5266b5
pkgname = stencyl
diff --git a/PKGBUILD b/PKGBUILD
index 281c939fe75a..9467724edba6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Sander Smid-Merlijn <sander..smid@gmail.com>
pkgname=stencyl
-pkgver=3.4.0
-pkgrel=2
+pkgver=4.0.1
+pkgrel=1
pkgdesc='Create amazing games without code'
-arch=(i686 x86_64)
+arch=(x86_64)
url=http://www.stencyl.com
license=(custom)
#depends=()
@@ -17,25 +17,19 @@ source=(stencyl
stencyl.png
LICENSE)
md5sums=('e97ff31637ae4f223062269bfce3f8ab'
- '6b52a9ecce3bddda2e77b3884503b888'
+ '97eccf2c15f9f40bac4aaebbfe06f976'
'c99ae55db267e86c0936e01662ee12ea'
'986e231db4a39dd7fa59c93a7e06b7c2')
-[ "$CARCH" = "i686" ] && {
- source+=("${pkgname}-linux.tar.gz::http://www.stencyl.com/download/get/lin32/")
- md5sums+=('3d41fe870d91b6acdd621d46ff00e9c7')
-}
-[ "$CARCH" = "x86_64" ] && {
- source+=("${pkgname}-linux.tar.gz::http://www.stencyl.com/download/get/lin64/")
- md5sums+=('398c65c78af155d8e1ed34fa58837102')
-}
-
-noextract=("$pkgname.tar.gz")
+archive="Stencyl-64-full.tar.gz"
+source+=("$archive::http://www.stencyl.com/download/get/lin64/")
+md5sums+=('3c1691239496ca02be97bb9fcd5266b5')
+noextract=("$achive")
package() {
# Uncompress the source into the final directory
install -Ddm755 "$pkgdir"/usr/share/stencyl
- tar -xzf "$srcdir/${pkgname}-linux.tar.gz" -C "$pkgdir"/usr/share/stencyl/
+ tar -xzf "$srcdir/$archive" -C "$pkgdir"/usr/share/stencyl/
# Install the custom launch script, the .desktop and the icon
install -Dm755 "$srcdir/stencyl" "$pkgdir/usr/bin/stencyl"