summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax2020-08-14 11:49:11 -0700
committerGitHub2020-08-14 11:49:11 -0700
commit8728a62d8f2b02831dea3cc00ecfa51da4c3fa11 (patch)
tree5a8b18ae9582b8d9b7d85ff6674aae2adf847a39
parentcf97bb7730f5083b0ad809e618f31806e7a71989 (diff)
parent6a7cb2dff0361a6ad605fc7cdb3ad217e90dde94 (diff)
downloadaur-8728a62d8f2b02831dea3cc00ecfa51da4c3fa11.tar.gz
Merge pull request #1 from tonyfinn/aarch64_support
AArch64 support
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4edab52c271..daf6b73511eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = step-ca-bin
pkgdesc = An online certificate authority and related tools for secure automated certificate management, so you can use TLS everywhere.
pkgver = 0.14.6
- pkgrel = 1
+ pkgrel = 2
url = https://smallstep.com/certificates
arch = x86_64
+ arch = aarch64
license = Apache
- source = https://github.com/smallstep/certificates/releases/download/v0.14.6/step-certificates_linux_0.14.6_amd64.tar.gz
- sha256sums = 3b026b5a1603eb6fae3b6f24dc78ef2e73e416f11fb5bcf0edaad5663ea1107c
+ source_x86_64 = https://github.com/smallstep/certificates/releases/download/v0.14.6/step-certificates_linux_0.14.6_amd64.tar.gz
+ sha256sums_x86_64 = 3b026b5a1603eb6fae3b6f24dc78ef2e73e416f11fb5bcf0edaad5663ea1107c
+ source_aarch64 = https://github.com/smallstep/certificates/releases/download/v0.14.6/step-certificates_linux_0.14.6_arm64.tar.gz
+ sha256sums_aarch64 = 851307a59a73843a907150ae8ec89b664af481c95816088ff4c6e3ad0e30d9ec
pkgname = step-ca-bin
diff --git a/PKGBUILD b/PKGBUILD
index ebe988d6966d..4696ff07e2d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,16 @@
_binname=step-ca
pkgname=$_binname-bin
pkgver=0.14.6
-pkgrel=1
+pkgrel=2
pkgdesc="An online certificate authority and related tools for secure automated certificate management, so you can use TLS everywhere."
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://smallstep.com/certificates"
license=('Apache')
-source=("https://github.com/smallstep/certificates/releases/download/v${pkgver}/step-certificates_linux_${pkgver}_amd64.tar.gz")
-sha256sums=('3b026b5a1603eb6fae3b6f24dc78ef2e73e416f11fb5bcf0edaad5663ea1107c')
+source_x86_64=("https://github.com/smallstep/certificates/releases/download/v${pkgver}/step-certificates_linux_${pkgver}_amd64.tar.gz")
+sha256sums_x86_64=('3b026b5a1603eb6fae3b6f24dc78ef2e73e416f11fb5bcf0edaad5663ea1107c')
+source_aarch64=("https://github.com/smallstep/certificates/releases/download/v${pkgver}/step-certificates_linux_${pkgver}_arm64.tar.gz")
+sha256sums_aarch64=("851307a59a73843a907150ae8ec89b664af481c95816088ff4c6e3ad0e30d9ec")
package() {
install -Dm755 "step-certificates_$pkgver/bin/$_binname" "$pkgdir/usr/bin/$_binname"