summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-09-16 23:15:28 -0400
committeracxz2020-09-16 23:15:28 -0400
commit72e3bf6c7984f9a1f816cb4e1bf6312b14050ab3 (patch)
treef568af1cfe8a46da8a2c377f9262a0e36faf8652
parent9efb1cf6dd9ab5aa73a64e9c11692a1c5091b69a (diff)
downloadaur-72e3bf6c7984f9a1f816cb4e1bf6312b14050ab3.tar.gz
[stepcode] fix install path
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD28
2 files changed, 10 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa239414b301..e1693ae850b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = stepcode
pkgdesc = Data exchange with ISO 10303. Used with IFC, STEP, and other standards to exchange data wit C++ and Python.
pkgver = 0.8
- pkgrel = 2
+ pkgrel = 3
url = https://stepcode.github.io
arch = i686
arch = x86_64
license = BSD 3-Clause
makedepends = cmake
depends = gcc
- source = https://github.com/stepcode/stepcode/archive/v0.8.tar.gz
+ source = stepcode-0.8.tar.gz::https://github.com/stepcode/stepcode/archive/v0.8.tar.gz
sha256sums = f9cc8a5a4193f97add595c1909433154f82983b892c532be2a696758b153fd2c
pkgname = stepcode
diff --git a/PKGBUILD b/PKGBUILD
index c49f67cfa0fd..bb4f11e75b3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=stepcode
pkgver=0.8
-pkgrel=2
+pkgrel=3
pkgdesc="Data exchange with ISO 10303. Used with IFC, STEP, and other standards
to exchange data wit C++ and Python."
arch=('i686' 'x86_64')
@@ -9,34 +9,22 @@ url="https://stepcode.github.io"
license=('BSD 3-Clause')
depends=('gcc')
makedepends=('cmake')
-_name=stepcode
-source=(https://github.com/stepcode/${_name}/archive/v${pkgver}.tar.gz)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/stepcode/${pkgname}/archive/v${pkgver}.tar.gz")
sha256sums=('f9cc8a5a4193f97add595c1909433154f82983b892c532be2a696758b153fd2c')
-_buildtype="Release"
-
build() {
- cd "${srcdir}/${_name}-${pkgver}"
-
- msg "Starting CMake (build type: ${_buildtype})"
-
- # Create a build directory
- mkdir -p "${srcdir}/${_name}-${pkgver}/build"
- cd "${srcdir}/${_name}-${pkgver}/build"
+ mkdir -p "${srcdir}/${pkgname}-${pkgver}/build"
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
cmake .. \
- -DCMAKE_BUILD_TYPE="${_buildtype}" \
- -DCMAKE_INSTALL_PREFIX="/usr"
- #-DCMAKE_INSTALL_LIBDIR="lib" \
+ -DSC_IS_SUBBUILD=false \
+ -DSC_BUILD_TYPE=Release \
+ -DSC_INSTALL_PREFIX="/usr"
- msg "Building the project"
make
}
package() {
- cd "${srcdir}/${_name}-${pkgver}/build"
-
- msg "Installing files"
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
make DESTDIR="${pkgdir}/" install
-
}