summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreyson Christoforo2021-06-27 22:48:50 +0100
committerGreyson Christoforo2021-06-27 22:48:50 +0100
commit1668b328108367605af95fb41c8c0f59439fbda1 (patch)
tree55e186cdf0f98910f45485f8a12f83a8a1b4e05a
downloadaur-1668b328108367605af95fb41c8c0f59439fbda1.tar.gz
initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD27
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e04255bcb296
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = stepreduce-git
+ pkgdesc = A deduplicating tool for step files
+ pkgver = r4.e89091c
+ pkgrel = 1
+ epoch = 0
+ url = https://gitlab.com/sethhillbrand/stepreduce
+ arch = x86_64
+ license = GPL3
+ source = git+https://gitlab.com/sethhillbrand/stepreduce.git
+ sha256sums = SKIP
+
+pkgname = stepreduce-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..920476eb9e69
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+stepreduce/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2c8c32162ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Grey Christoforo <first name at last name dot net>
+pkgname=stepreduce-git
+pkgver=r4.e89091c
+pkgrel=1
+epoch=0
+pkgdesc="A deduplicating tool for step files"
+arch=(x86_64)
+url="https://gitlab.com/sethhillbrand/stepreduce"
+license=('GPL3')
+source=(git+https://gitlab.com/sethhillbrand/stepreduce.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd stepreduce
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd stepreduce
+ #./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd stepreduce
+ install -Dt "${pkgdir}/usr/bin" -m0755 stepreduce
+}