summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeimos2018-09-29 13:07:20 -0400
committerDeimos2018-09-29 13:07:20 -0400
commit78949cd295c5d072f664f835498809c772e2fe2b (patch)
tree40371eee43853bbf586d5e7773f712528959148b
downloadaur-78949cd295c5d072f664f835498809c772e2fe2b.tar.gz
Stage for AUR
-rw-r--r--.SRCINFO20
-rwxr-xr-xPKGBUILD27
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b41f435ab6f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = stepsync.app
+ pkgdesc = A a file and folder synchronization tool
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://gap.nongnu.org/stepsync/index.html
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ groups = gnustep-apps
+ license = GPL
+ makedepends = gcc-objc
+ makedepends = gnustep-make
+ depends = gnustep-base
+ depends = gnustep-gui
+ depends = gnustep-back
+ source = http://savannah.nongnu.org/download/gap/StepSync-1.0.tar.gz
+ sha256sums = 97ccd23828280ba54235240413718bb96c7403763709848ef327e3cb93e39d38
+
+pkgname = stepsync.app
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..cfaf67399812
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Icarus Mitchellson <mumei AT airmail DOT cc>
+
+_pkgname=StepSync
+pkgname=stepsync.app
+pkgrel=1
+pkgver=1.0
+pkgdesc='A a file and folder synchronization tool'
+arch=('i686' 'x86_64' 'armv7h')
+url='http://gap.nongnu.org/stepsync/index.html'
+license=('GPL')
+groups=('gnustep-apps')
+depends=('gnustep-base' 'gnustep-gui' 'gnustep-back')
+makedepends=('gcc-objc' 'gnustep-make')
+source=("http://savannah.nongnu.org/download/gap/StepSync-1.0.tar.gz")
+sha256sums=('97ccd23828280ba54235240413718bb96c7403763709848ef327e3cb93e39d38')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ export GNUSTEP_MAKEFILES="$(gnustep-config --variable=GNUSTEP_MAKEFILES)"
+ make
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+}