summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-06-23 23:33:37 -0400
committerJean Lucas2019-06-23 23:33:37 -0400
commitf9caed035547932e9d518921ae302f489729c98a (patch)
treea7ea9e5ad4c33839b8afb04fb4edb5cbbfd645fd
parentd2fac7127d0e1dfec775451198767907719b1a70 (diff)
downloadaur-f9caed035547932e9d518921ae302f489729c98a.tar.gz
Version bump, change pkgver scheme, use HTTPS URL
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8d550621d03..066da38152f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Fri Apr 12 20:53:52 UTC 2019
pkgbase = stf-git
pkgdesc = Web application for controlling and managing Android devices (git)
- pkgver = 3.4.0+12+gcdb607a8
- pkgrel = 2
+ pkgver = 3.4.1+r2+g5ff96f54
+ pkgrel = 1
url = https://openstf.io
arch = i686
arch = x86_64
@@ -20,7 +18,7 @@ pkgbase = stf-git
provides = stf
conflicts = stf
options = !strip
- source = git+http://github.com/openstf/stf
+ source = git+https://github.com/openstf/stf
sha512sums = SKIP
pkgname = stf-git
diff --git a/PKGBUILD b/PKGBUILD
index b94ca91a1b66..d6e93c8cd1dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=stf-git
-pkgver=3.4.0+12+gcdb607a8
-pkgrel=2
+pkgver=3.4.1+r2+g5ff96f54
+pkgrel=1
pkgdesc='Web application for controlling and managing Android devices (git)'
arch=(i686 x86_64)
url=https://openstf.io
@@ -19,23 +19,23 @@ makedepends=(npm)
provides=(stf)
conflicts=(stf)
options=(!strip)
-source=(git+http://github.com/openstf/stf)
+source=(git+https://github.com/openstf/stf)
sha512sums=(SKIP)
pkgver() {
cd stf
- git describe --tags | sed 's/v//;s/-/+/g'
+ git describe --tags | sed 's#v##;s#-#+#g;s#+#+r#'
}
build() {
cd stf
- npm install
+ npm i
}
package() {
cd stf
- install -d "$pkgdir"/usr/{share/stf,bin,share/licenses/stf}
+ install -d "$pkgdir"/usr/{share/stf,bin}
cp -a . "$pkgdir"/usr/share/stf
ln -s /usr/share/stf/bin/stf "$pkgdir"/usr/bin/stf
- cp LICENSE "$pkgdir"/usr/share/licenses/stf
+ install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/stf
}