summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-12-06 11:15:35 -0700
committerMark Wagie2021-12-06 11:15:35 -0700
commit11b64480d4cd0fcaafc49149ea3a2f45e294edfc (patch)
treef9281c9553ebfd89d4c88b130783ec24f8c76c45
parent000a32dce2825afae5b05eec58f291b3a8d385e2 (diff)
downloadaur-11b64480d4cd0fcaafc49149ea3a2f45e294edfc.tar.gz
About dialog fixes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e94132cbbe99..5bef134e141c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sticky-git
pkgdesc = A sticky notes app for the Linux desktop
- pkgver = 1.2.r21.g6d6b1ce
+ pkgver = 1.4.r0.g45c90a4
pkgrel = 1
url = https://github.com/collinss/sticky
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index db6d46c3c21a..734a14ab67a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Mark Wagie <mark.wagie at tutanota dot com>
pkgname=sticky-git
-pkgver=1.2.r21.g6d6b1ce
+pkgver=1.4.r0.g45c90a4
pkgrel=1
pkgdesc="A sticky notes app for the Linux desktop"
arch=('any')
@@ -18,9 +18,20 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+
+ # Set version in About dialog
+ sed -i "s/__DEB_VERSION__/${pkgver//+*/}/g" "usr/lib/${pkgname%-git}/${pkgname%-git}.py"
+
+ # Fix license path
+ sed -i 's|common-licenses/GPL|licenses/common/GPL/license.txt|g' \
+ "usr/lib/${pkgname%-git}/${pkgname%-git}.py"
+}
+
build() {
cd "$srcdir/${pkgname%-git}"
- make buildmo
+ make
}
package() {