summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-10-01 17:40:41 -0600
committerMark Wagie2020-10-01 17:40:41 -0600
commit89082a4f64289058ee3eb52a4265c77d9dfe03ab (patch)
tree0acfbe0b359d090e5b52d8ee452b92ee1bd11f85
downloadaur-89082a4f64289058ee3eb52a4265c77d9dfe03ab.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD27
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e7f68c4d67f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = sticky-git
+ pkgdesc = A sticky notes app for the Linux desktop
+ pkgver = 0.0.1.r33.9f12863
+ pkgrel = 1
+ url = https://github.com/collinss/sticky
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = gtk3
+ depends = xapp
+ depends = gspell
+ depends = python-gobject
+ depends = python-xapp
+ optdepends = lipappindicator-gtk3: for tray icon
+ provides = sticky
+ conflicts = sticky
+ source = git+https://github.com/collinss/sticky.git
+ sha256sums = SKIP
+
+pkgname = sticky-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e13a57561d7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Mark Wagie <mark.wagie at tutanota dot com>
+pkgname=sticky-git
+pkgver=0.0.1.r33.9f12863
+pkgrel=1
+pkgdesc="A sticky notes app for the Linux desktop"
+arch=('x86_64')
+url="https://github.com/collinss/sticky"
+license=('GPL')
+depends=('gtk3' 'xapp' 'gspell' 'python-gobject' 'python-xapp')
+makedepends=('git')
+optdepends=('lipappindicator-gtk3: for tray icon')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/collinss/sticky.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s.r%s.%s" "$(head -n 1 debian/changelog | cut -d'(' -f 2 | cut -d')' -f 1 | \
+ sed 's/-/./')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ cp -r usr "$pkgdir"
+ chmod +x "$pkgdir/usr/bin/${pkgname%-git}"
+}