summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-05-08 10:33:53 -0600
committerMark Wagie2023-05-08 10:33:53 -0600
commite526e3b4248b986d57d0a5bec291bb41277bf9cd (patch)
treef067a938fea4993ac91236472793dfba75c67bb2
parent03461d1b763da7f45fb04c0779f158b3003f6214 (diff)
downloadaur-e526e3b4248b986d57d0a5bec291bb41277bf9cd.tar.gz
ensure yarn cache is local
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc00e92586f6..74aa44cfc703 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sticky-notes
pkgdesc = A simple sticky notes app
pkgver = 0.1.11
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/vixalien/sticky
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 3c3d2d43c545..da6bb4fa4b4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=sticky-notes
pkgver=0.1.11
-pkgrel=1
+pkgrel=2
pkgdesc="A simple sticky notes app"
arch=('any')
url="https://github.com/vixalien/sticky"
@@ -31,8 +31,9 @@ prepare() {
}
build() {
- yarn config set cache-folder "$srcdir/yarn-cache"
+ export YARN_CACHE_FOLDER="$srcdir/yarn-cache"
yarn install
+
arch-meson sticky build
meson compile -C build
}
@@ -42,7 +43,7 @@ check() {
}
package() {
- meson install -C build --destdir "$pkgdir"
+ meson install -C build --no-rebuild --destdir "$pkgdir"
cd "$srcdir/sticky"
install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$pkgname/"