summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-03-03 09:57:40 -0700
committerMark Wagie2023-03-03 09:57:40 -0700
commite8e40bf04e5f657953410c9b357078b3d9c14672 (patch)
tree216e6e3368b8b3b290c7c6af243fbdb3cfe82fe1
downloadaur-e8e40bf04e5f657953410c9b357078b3d9c14672.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD48
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..74324f8cf03b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = sticky-notes
+ pkgdesc = A simple sticky notes app
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/vixalien/sticky
+ arch = any
+ license = MIT
+ checkdepends = appstream-glib
+ makedepends = git
+ makedepends = gobject-introspection
+ makedepends = meson
+ makedepends = yarn
+ depends = gjs
+ depends = libadwaita
+ source = git+https://github.com/vixalien/sticky.git#commit=9a750614323e630547443c3f10c67311630f58b0
+ source = git+https://gitlab.gnome.org/BrainBlasted/gi-typescript-definitions.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = sticky-notes
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c683de68ab6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
+pkgname=sticky-notes
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="A simple sticky notes app"
+arch=('any')
+url="https://github.com/vixalien/sticky"
+license=('MIT')
+depends=('gjs' 'libadwaita')
+makedepends=('git' 'gobject-introspection' 'meson' 'yarn')
+checkdepends=('appstream-glib')
+_commit=9a750614323e630547443c3f10c67311630f58b0 # tags/v0.1.1^0
+source=("git+https://github.com/vixalien/sticky.git#commit=$_commit"
+ 'git+https://gitlab.gnome.org/BrainBlasted/gi-typescript-definitions.git')
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$srcdir/sticky"
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
+
+prepare() {
+ cd "$srcdir/sticky"
+ git submodule init
+ git config submodule.gi-types.url "$srcdir/gi-typescript-definitions"
+ git -c protocol.file.allow=always submodule update
+}
+
+build() {
+ yarn config set cache-folder "$srcdir/yarn-cache"
+ yarn install
+ arch-meson sticky build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs || :
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+
+ cd "$srcdir/sticky"
+ install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$pkgname/"
+
+ ln -s /usr/bin/com.vixalien.sticky "$pkgdir/usr/bin/$pkgname"
+}