summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKazuo Teramoto2017-10-20 14:54:16 -0200
committerKazuo Teramoto2017-10-20 14:54:16 -0200
commita8f8582157f712aa6fb9704edf93b1a167b95fdc (patch)
treebc30991552fa9f1d0f94efa3eb874d60781b762a
parent3ae62f53edfca22a1e3f0469ff7cc3138ef4e947 (diff)
downloadaur-a8f8582157f712aa6fb9704edf93b1a167b95fdc.tar.gz
Change dep from `python-appdirs` to `python-xdg`
Upstream uses https://pypi.python.org/pypi/xdg and `extra/python-xdg` packages https://pypi.python.org/pypi/pyxdg. Because it is only used to get the value of XDG_CONFIG_HOME and XDG_CACHE_HOME just patch the source to use the syntax of the one packaged in Arch.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--fix_xdg_dep_on_arch.patch27
3 files changed, 37 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 670670761302..902a18476bf9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = stig-git
pkgdesc = TUI and CLI client for the Transmission daemon
- pkgver = 0.7.0a.r0.b0d20e3
+ pkgver = 0.7.3a.r524.b763aca
pkgrel = 1
url = https://github.com/rndusr/stig
arch = any
@@ -11,14 +11,16 @@ pkgbase = stig-git
depends = python-urwid
depends = python-urwidtrees-git
depends = python-aiohttp
- depends = python-appdirs
+ depends = python-xdg
depends = python-blinker
depends = python-natsort
optdepends = python-geoip: shows country codes in peer lists
provides = stig
conflicts = stig
source = git+https://github.com/rndusr/stig.git#branch=dev
+ source = fix_xdg_dep_on_arch.patch
sha256sums = SKIP
+ sha256sums = 274f56f53c8eeb582c26dba53cf01cd8a91bec88d24f80a9fc72c423064fb479
pkgname = stig-git
diff --git a/PKGBUILD b/PKGBUILD
index 5d9d8120021b..5b8f41db9f96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,21 @@
pkgbase=('stig-git')
pkgname=('stig-git')
-pkgver=0.7.0a.r0.b0d20e3
+pkgver=0.7.3a.r524.b763aca
pkgrel=1
pkgdesc='TUI and CLI client for the Transmission daemon'
url='https://github.com/rndusr/stig'
depends=('python' 'python-urwid' 'python-urwidtrees-git' 'python-aiohttp'
- 'python-appdirs' 'python-blinker' 'python-natsort')
+ 'python-xdg' 'python-blinker' 'python-natsort')
makedepends=('git' 'python-setuptools')
optdepends=('python-geoip: shows country codes in peer lists')
license=('GPL')
arch=('any')
provides=('stig')
conflicts=('stig')
-source=("git+https://github.com/rndusr/stig.git#branch=dev")
-sha256sums=('SKIP')
+source=("git+https://github.com/rndusr/stig.git#branch=dev" "fix_xdg_dep_on_arch.patch")
+sha256sums=('SKIP'
+ '274f56f53c8eeb582c26dba53cf01cd8a91bec88d24f80a9fc72c423064fb479')
pkgver() {
cd stig
@@ -24,6 +25,7 @@ pkgver() {
build() {
cd stig
+ patch -p1 -i "${srcdir}/fix_xdg_dep_on_arch.patch"
python setup.py build
}
diff --git a/fix_xdg_dep_on_arch.patch b/fix_xdg_dep_on_arch.patch
new file mode 100644
index 000000000000..3207d2af1070
--- /dev/null
+++ b/fix_xdg_dep_on_arch.patch
@@ -0,0 +1,27 @@
+diff --git i/setup.py w/setup.py
+index 3306e73..b9b32e6 100644
+--- i/setup.py
++++ w/setup.py
+@@ -33,7 +33,7 @@ setup(
+ 'urwid>=1.3.0',
+ 'urwidtrees>=1.0.3dev0',
+ 'aiohttp>=0.22.5',
+- 'xdg',
++ 'pyxdg',
+ 'blinker',
+ 'natsort',
+ ],
+diff --git i/stig/settings/defaults.py w/stig/settings/defaults.py
+index 59a51eb..f35d6fc 100644
+--- i/stig/settings/defaults.py
++++ w/stig/settings/defaults.py
+@@ -13,7 +13,8 @@ from ..logging import make_logger
+ log = make_logger(__name__)
+
+ import os
+-from xdg import (XDG_CONFIG_HOME, XDG_CACHE_HOME)
++from xdg.BaseDirectory import xdg_config_home as XDG_CONFIG_HOME
++from xdg.BaseDirectory import xdg_cache_home as XDG_CACHE_HOME
+
+ from .. import APPNAME
+ from ..views.torrentlist import COLUMNS as TORRENT_COLUMNS