summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Bruhin2012-11-01 16:01:40 +0100
committerFlorian Bruhin2012-11-01 16:01:40 +0100
commit861de7fc42626dfa64685a7b7e9da0b0082d8f15 (patch)
tree5266589539a0e822c23b9e784bfba32d68345fbe
downloadaur-861de7fc42626dfa64685a7b7e9da0b0082d8f15.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--stikked.install24
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2eca5c00108e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = stikked
+ pkgdesc = An advanced and beautiful pastebin written in PHP
+ pkgver = 0.8.4
+ pkgrel = 1
+ url = https://github.com/claudehohl/Stikked
+ install = stikked.install
+ arch = any
+ license = GPL
+ depends = php
+ conflicts = stikked-git
+ options = !strip
+ source = stikked-0.8.4.zip::https://github.com/claudehohl/Stikked/zipball/0.8.4
+ md5sums = 40b4729d7221d58d3373bb8fe3a784b7
+
+pkgname = stikked
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36b9e220588b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Florian Bruhin (The Compiler) <archlinux.org@the-compiler.org>
+
+pkgname=stikked
+pkgver=0.8.4
+pkgrel=1
+pkgdesc="An advanced and beautiful pastebin written in PHP"
+arch=('any')
+url="https://github.com/claudehohl/Stikked"
+license=('GPL')
+depends=('php')
+conflicts=('stikked-git')
+options=('!strip')
+install=$pkgname.install
+source=("stikked-$pkgver.zip::https://github.com/claudehohl/Stikked/zipball/$pkgver")
+md5sums=('40b4729d7221d58d3373bb8fe3a784b7')
+
+package() {
+ cd "$srcdir"/claudehohl-Stikked-*/htdocs
+ _instdir="$pkgdir/usr/share/webapps/Stikked"
+ _cfgdir="$pkgdir/etc/webapps/stikked"
+ mkdir -p "$_instdir" "$_cfgdir"
+
+ cp -ra * .htaccess "$_instdir"
+ mv "$_instdir/application/config/stikked.php" "$_cfgdir"
+ ln -s /etc/webapps/stikked/stikked.php "$_instdir/application/config/stikked.php"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/stikked.install b/stikked.install
new file mode 100644
index 000000000000..4e958fc8049e
--- /dev/null
+++ b/stikked.install
@@ -0,0 +1,24 @@
+# Maintainer: Florian Bruhin (The Compiler) <archlinux.org@the-compiler.org>
+
+post_install() {
+ echo "You should now create an user and a database for Stikked"
+ echo "then edit the config in /etc/webapps/stikked/stikked.php."
+ echo
+ echo "The database structure will be created automatically if it doesn't"
+ echo "exist."
+ echo
+ echo "No special file permissions are needed by default. Optional: If you"
+ echo "want to have the JavaScript- and CSS-files minified, the"
+ echo "/usr/share/webapps/Stikked/static/asset/ folder has to be writable."
+}
+
+post_upgrade() {
+ post_install
+ echo
+ echo "If you upgrade from a version before 0.8.2, you should execute this"
+ echo "MySQL statement:"
+ echo
+ echo "ALTER TABLE pastes DROP paste;"
+}
+
+# vim:set ts=2 sw=2 et: