summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Bruhin2013-08-14 16:19:47 +0200
committerFlorian Bruhin2013-08-14 16:19:47 +0200
commitfb2b218d3f0fa788f805fe64ac2a35fff0a0d40d (patch)
treef7e4348adefc82d86c62379023bde031b854ab31
parent861de7fc42626dfa64685a7b7e9da0b0082d8f15 (diff)
downloadaur-fb2b218d3f0fa788f805fe64ac2a35fff0a0d40d.tar.gz
Update stikked to 0.8.5
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2eca5c00108e..3a2f069bca20 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = stikked
pkgdesc = An advanced and beautiful pastebin written in PHP
- pkgver = 0.8.4
- pkgrel = 1
+ pkgver = 0.8.5
+ pkgrel = 2
url = https://github.com/claudehohl/Stikked
install = stikked.install
arch = any
license = GPL
depends = php
conflicts = stikked-git
- options = !strip
- source = stikked-0.8.4.zip::https://github.com/claudehohl/Stikked/zipball/0.8.4
- md5sums = 40b4729d7221d58d3373bb8fe3a784b7
+ backup = etc/webapps/stikked/stikked.php
+ source = stikked-0.8.5.zip::https://github.com/claudehohl/Stikked/zipball/0.8.5
+ sha1sums = e941a0a9b3299cfbf2c14651650418da00068ab0
pkgname = stikked
diff --git a/PKGBUILD b/PKGBUILD
index 36b9e220588b..e3aa5409c7c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,28 @@
# Maintainer: Florian Bruhin (The Compiler) <archlinux.org@the-compiler.org>
pkgname=stikked
-pkgver=0.8.4
-pkgrel=1
+pkgver=0.8.5
+pkgrel=2
pkgdesc="An advanced and beautiful pastebin written in PHP"
arch=('any')
url="https://github.com/claudehohl/Stikked"
license=('GPL')
depends=('php')
conflicts=('stikked-git')
-options=('!strip')
+backup=('etc/webapps/stikked/stikked.php')
install=$pkgname.install
source=("stikked-$pkgver.zip::https://github.com/claudehohl/Stikked/zipball/$pkgver")
-md5sums=('40b4729d7221d58d3373bb8fe3a784b7')
+sha1sums=('e941a0a9b3299cfbf2c14651650418da00068ab0')
package() {
cd "$srcdir"/claudehohl-Stikked-*/htdocs
- _instdir="$pkgdir/usr/share/webapps/Stikked"
- _cfgdir="$pkgdir/etc/webapps/stikked"
- mkdir -p "$_instdir" "$_cfgdir"
- cp -ra * .htaccess "$_instdir"
- mv "$_instdir/application/config/stikked.php" "$_cfgdir"
- ln -s /etc/webapps/stikked/stikked.php "$_instdir/application/config/stikked.php"
+ mkdir -p "$pkgdir/usr/share/webapps/Stikked" "$pkgdir/etc/webapps/stikked"
+ cp -ra * .htaccess "$pkgdir/usr/share/webapps/Stikked"
+ mv "$pkgdir/usr/share/webapps/Stikked/application/config/stikked.php" \
+ "$pkgdir/etc/webapps/stikked"
+ ln -s "/etc/webapps/stikked/stikked.php" \
+ "$pkgdir/usr/share/webapps/Stikked/application/config/stikked.php"
}
# vim:set ts=2 sw=2 et: