summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Bruhin2013-08-14 16:19:30 +0200
committerFlorian Bruhin2013-08-14 16:19:30 +0200
commit5ea2e52ae3cf903c118d69a12f7254f94477b94a (patch)
treedd4244ef4ad0e06a3599b42f1e28d3363910130d
parent76dc02274dd706ad93d90387ef58153aff113ef1 (diff)
downloadaur-5ea2e52ae3cf903c118d69a12f7254f94477b94a.tar.gz
Change stikked-git to pacman4
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD44
2 files changed, 18 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e2ece5c8c00..a07a0b66d72f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = stikked-git
pkgdesc = An advanced and beautiful pastebin written in PHP
- pkgver = 20120706
+ pkgver = 0.8.5.2.g2ab968b
pkgrel = 1
url = https://github.com/claudehohl/Stikked
install = stikked-git.install
@@ -9,8 +9,9 @@ pkgbase = stikked-git
depends = php
provides = stikked
conflicts = stikked
- options = !strip
backup = etc/webapps/stikked/stikked.php
+ source = git+https://github.com/claudehohl/Stikked.git
+ sha1sums = SKIP
pkgname = stikked-git
diff --git a/PKGBUILD b/PKGBUILD
index 00bb392a6cec..bcd17af81e42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Florian Bruhin (The Compiler) <archlinux.org@the-compiler.org>
pkgname=stikked-git
-pkgver=20120706
+_gitname='Stikked'
+pkgver=0.8.5.2.g2ab968b
pkgrel=1
pkgdesc="An advanced and beautiful pastebin written in PHP"
arch=('any')
@@ -11,39 +12,24 @@ depends=('php')
provides=('stikked')
conflicts=('stikked')
backup=('etc/webapps/stikked/stikked.php')
-options=('!strip')
install=$pkgname.install
+source=('git+https://github.com/claudehohl/Stikked.git')
+sha1sums=('SKIP')
-_gitroot='https://github.com/claudehohl/Stikked.git'
-_gitname='Stikked'
-
-build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [[ -d "$_gitname" ]]; then
- cd "$_gitname" && git pull origin
- msg "The local files are updated."
- else
- git clone "$_gitroot" "$_gitname"
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting build..."
-
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe --always | sed 's|-|.|g'
}
package() {
- cd "$srcdir/$_gitname-build/htdocs"
- _instdir="$pkgdir/usr/share/webapps/Stikked"
- _cfgdir="$pkgdir/etc/webapps/stikked"
- mkdir -p "$_instdir" "$_cfgdir"
-
- cp -ra * .htaccess "$_instdir"
- mv "$_instdir/application/config/stikked.php" "$_cfgdir"
- ln -s /etc/webapps/stikked/stikked.php "$_instdir/application/config/stikked.php"
+ cd "$srcdir/$_gitname/htdocs"
+
+ mkdir -p "$pkgdir/usr/share/webapps/Stikked" "$pkgdir/etc/webapps/stikked"
+ cp -ra * .htaccess "$pkgdir/usr/share/webapps/Stikked"
+ mv "$pkgdir/usr/share/webapps/Stikked/application/config/stikked.php" \
+ "$pkgdir/etc/webapps/stikked"
+ ln -s "/etc/webapps/stikked/stikked.php" \
+ "$pkgdir/usr/share/webapps/Stikked/application/config/stikked.php"
}
# vim:set ts=2 sw=2 et: