summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Bruhin2012-11-01 16:01:40 +0100
committerFlorian Bruhin2012-11-01 16:01:40 +0100
commit76dc02274dd706ad93d90387ef58153aff113ef1 (patch)
treed096354a41e576bc5dcb617cca44ab84613f3b86
downloadaur-76dc02274dd706ad93d90387ef58153aff113ef1.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD49
-rw-r--r--stikked-git.install24
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e2ece5c8c00
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = stikked-git
+ pkgdesc = An advanced and beautiful pastebin written in PHP
+ pkgver = 20120706
+ pkgrel = 1
+ url = https://github.com/claudehohl/Stikked
+ install = stikked-git.install
+ arch = any
+ license = GPL
+ depends = php
+ provides = stikked
+ conflicts = stikked
+ options = !strip
+ backup = etc/webapps/stikked/stikked.php
+
+pkgname = stikked-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00bb392a6cec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Florian Bruhin (The Compiler) <archlinux.org@the-compiler.org>
+
+pkgname=stikked-git
+pkgver=20120706
+pkgrel=1
+pkgdesc="An advanced and beautiful pastebin written in PHP"
+arch=('any')
+url="https://github.com/claudehohl/Stikked"
+license=('GPL')
+depends=('php')
+provides=('stikked')
+conflicts=('stikked')
+backup=('etc/webapps/stikked/stikked.php')
+options=('!strip')
+install=$pkgname.install
+
+_gitroot='https://github.com/claudehohl/Stikked.git'
+_gitname='Stikked'
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+}
+
+package() {
+ cd "$srcdir/$_gitname-build/htdocs"
+ _instdir="$pkgdir/usr/share/webapps/Stikked"
+ _cfgdir="$pkgdir/etc/webapps/stikked"
+ mkdir -p "$_instdir" "$_cfgdir"
+
+ cp -ra * .htaccess "$_instdir"
+ mv "$_instdir/application/config/stikked.php" "$_cfgdir"
+ ln -s /etc/webapps/stikked/stikked.php "$_instdir/application/config/stikked.php"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/stikked-git.install b/stikked-git.install
new file mode 100644
index 000000000000..4e958fc8049e
--- /dev/null
+++ b/stikked-git.install
@@ -0,0 +1,24 @@
+# Maintainer: Florian Bruhin (The Compiler) <archlinux.org@the-compiler.org>
+
+post_install() {
+ echo "You should now create an user and a database for Stikked"
+ echo "then edit the config in /etc/webapps/stikked/stikked.php."
+ echo
+ echo "The database structure will be created automatically if it doesn't"
+ echo "exist."
+ echo
+ echo "No special file permissions are needed by default. Optional: If you"
+ echo "want to have the JavaScript- and CSS-files minified, the"
+ echo "/usr/share/webapps/Stikked/static/asset/ folder has to be writable."
+}
+
+post_upgrade() {
+ post_install
+ echo
+ echo "If you upgrade from a version before 0.8.2, you should execute this"
+ echo "MySQL statement:"
+ echo
+ echo "ALTER TABLE pastes DROP paste;"
+}
+
+# vim:set ts=2 sw=2 et: