summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoregnappahz2021-11-23 08:15:58 +0100
committeregnappahz2021-11-23 08:15:58 +0100
commit31d2aac44c56ebf3cddc73b612b29c6481c9a552 (patch)
tree84b8df5dfb25458f69d3a3036595234a73419591
parentc777bf1ba12fc04a6c00703161989b085a2e6cbb (diff)
downloadaur-31d2aac44c56ebf3cddc73b612b29c6481c9a552.tar.gz
Fixed deprecated ytdl dep
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--stillalive.sh2
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d39c1b0593f4..a63b13158c53 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = stillalive
pkgdesc = Log into GLaDOS to see the "still alive" message in realtime!
pkgver = 1
- pkgrel = 1
+ pkgrel = 2
url = https://www.ffmpeg.org/
arch = x86_64
license = GPL3
depends = mplayer
- depends = youtube-dl
+ depends = yt-dlp
depends = bash
provides = stillalive.sh
source = stillalive.sh
- sha256sums = ea98b0e4554f4ddc384845db60c53332b95b3f87ddd678236138b99f400c7e41
+ sha256sums = 993001c8f621593d959a0c3e324ff8daaf9b3f57b89422f9477037fdd80da54f
pkgname = stillalive
diff --git a/PKGBUILD b/PKGBUILD
index 00ce21bfd597..3a81efa6c1ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
pkgname=stillalive
pkgver=1
gitver=n${pkgver}
-pkgrel=1
+pkgrel=2
pkgdesc='Log into GLaDOS to see the "still alive" message in realtime!'
arch=('x86_64')
url='https://www.ffmpeg.org/'
license=('GPL3')
depends=(
'mplayer'
- 'youtube-dl'
+ 'yt-dlp'
'bash'
)
provides=('stillalive.sh')
source=("stillalive.sh")
-sha256sums=('ea98b0e4554f4ddc384845db60c53332b95b3f87ddd678236138b99f400c7e41')
+sha256sums=('993001c8f621593d959a0c3e324ff8daaf9b3f57b89422f9477037fdd80da54f')
prepare() {
echo "GLaDOS booting up ..."
diff --git a/stillalive.sh b/stillalive.sh
index 56003c64d346..78389750f61e 100644
--- a/stillalive.sh
+++ b/stillalive.sh
@@ -164,7 +164,7 @@ echo ' .-;+$XXHHHHHX$+;-. '
#Prereqs & Preparation
echo -e "${BYELLOW}DEBUG: Checkin needed binaries...${NOCOLOR}"
which mplayer || exit 2
-which youtube-dl || exit 2
+which yt-dlp || exit 2
echo -e "${BGREEN}DEBUG: You have all the binaries you need!...${NOCOLOR}"
if ! [ -f /var/cache/stillalive/Portal_-_Still_Alive.mp3 ]; then