summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2015-06-08 11:31:28 -1000
committerGaetan Bisson2015-06-08 11:31:28 -1000
commitb24780ea3deaca0658200c8d16086e68d215a700 (patch)
treefc94126d0372961f0aa29e40381980a1669a5ca5
downloadaur-b24780ea3deaca0658200c8d16086e68d215a700.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..500983de847f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = stirfs
+ pkgdesc = Secure, transparent and irresistible filesystem
+ pkgver = 1.5
+ pkgrel = 1
+ url = http://fenua.org/gaetan/src/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = ISC
+ depends = fuse
+ depends = openssl
+ source = http://fenua.org/gaetan/src//stirfs-1.5.c
+ sha1sums = e832af2179f9224b5572c0b92767733d10f60a2b
+
+pkgname = stirfs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb0044a46973
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+
+pkgname=stirfs
+pkgver=1.5
+pkgrel=1
+pkgdesc='Secure, transparent and irresistible filesystem'
+url='http://fenua.org/gaetan/src/'
+license=('ISC')
+depends=('fuse' 'openssl')
+arch=('i686' 'x86_64' 'armv7h')
+source=("${url}/${pkgname}-${pkgver}.c")
+sha1sums=('e832af2179f9224b5572c0b92767733d10f60a2b')
+
+build() {
+ cd "${srcdir}"
+ cc -lfuse -lcrypto \
+ ${CFLAGS} ${LDFLAGS} \
+ -o ${pkgname} ${pkgname}-${pkgver}.c
+}
+
+package() {
+ cd "${srcdir}"
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ head -n 15 "${pkgname}-${pkgver}.c" > "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}