summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpzl2015-08-08 11:55:13 -0400
committerpzl2015-08-08 11:55:13 -0400
commite7bc088109539eb607da05d84ca72ee37ab7526e (patch)
tree48340439a1f770953c729f87af3082790418be91
downloadaur-e7bc088109539eb607da05d84ca72ee37ab7526e.tar.gz
move this package into aur4/git
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
-rw-r--r--stitchy.desktop17
-rw-r--r--stitchy.install10
4 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f25beca34682
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = stitchy-git
+ pkgdesc = Cross stitch pattern designer.
+ pkgver = 7610be8
+ pkgrel = 1
+ url = https://github.com/segfault87/stitchy
+ install = stitchy.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = qjson
+ source = git://github.com/segfault87/stitchy.git
+ source = stitchy.desktop
+ md5sums = SKIP
+ md5sums = 126841e4b1ff8c8ab949b6be1b2a801c
+
+pkgname = stitchy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0568cdb62906
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: pzl <alsoelp@gmail.com>
+# Contributor: Diego <cdprincipe@at@gmail@dot@com>
+# Contributor: Frikilinux <frikilinux@gmail.com.ar>
+
+_pkgname=stitchy
+pkgname=stitchy-git
+pkgver=7610be8
+pkgrel=1
+pkgdesc="Cross stitch pattern designer."
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('qjson')
+makedepends=('git')
+url="https://github.com/segfault87/stitchy"
+install=stitchy.install
+source=(git://github.com/segfault87/stitchy.git
+ stitchy.desktop)
+md5sums=('SKIP'
+ '126841e4b1ff8c8ab949b6be1b2a801c')
+
+
+pkgver() {
+ cd $srcdir/$_pkgname
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd $srcdir/$_pkgname
+ qmake-qt4
+ make
+}
+
+package() {
+ cd $srcdir/$_pkgname
+ install -Dm755 stitchy "$pkgdir/usr/bin/stitchy"
+ install -Dm644 $srcdir/stitchy.desktop "${pkgdir}/usr/share/applications/stitchy.desktop"
+ install -Dm644 $srcdir/stitchy/icons/fallback/stitch-full.png "${pkgdir}/usr/share/pixmaps/stitchy.png"
+}
+
diff --git a/stitchy.desktop b/stitchy.desktop
new file mode 100644
index 000000000000..56959c1ff423
--- /dev/null
+++ b/stitchy.desktop
@@ -0,0 +1,17 @@
+[Desktop Entry]
+Version=1.0
+
+Type=Application
+
+Name=Stitchy
+_GenericName=Cross stitch editor
+_Comment=Cross stitch pattern designer
+Icon=stitchy
+
+Categories=GTK;Graphics;
+
+Exec=stitchy %F
+TryExec=stitchy
+Terminal=false
+StartupNotify=true
+
diff --git a/stitchy.install b/stitchy.install
new file mode 100644
index 000000000000..ff5a644bd6ac
--- /dev/null
+++ b/stitchy.install
@@ -0,0 +1,10 @@
+post_install() {
+ gtk-update-icon-cache -q -f -t usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -f -t usr/share/icons/hicolor
+ update-desktop-database -q
+}
+