summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorunlimitedbacon2022-04-12 15:17:50 -0700
committerunlimitedbacon2022-04-12 15:17:50 -0700
commit07f0370fdb326d7534d15f66d26c32145e65f196 (patch)
tree4748e5f0735d84ec60e651cd749784fb9b21e4cd
parent8ba17c02b78b5d24e4adc7cc7eb5dc4a16d8a99f (diff)
downloadaur-07f0370fdb326d7534d15f66d26c32145e65f196.tar.gz
Updated Git source
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8f525e4d0cc..8db1824f6fdc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = stl-thumb
pkgdesc = A fast lightweight thumbnail generator for STL files
pkgver = 0.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/unlimitedbacon/stl-thumb
arch = i386
arch = x86_64
@@ -9,8 +9,7 @@ pkgbase = stl-thumb
makedepends = rust
makedepends = git
depends = libgl
- source = git://github.com/unlimitedbacon/stl-thumb.git
+ source = git+https://github.com/unlimitedbacon/stl-thumb.git
sha256sums = SKIP
pkgname = stl-thumb
-
diff --git a/PKGBUILD b/PKGBUILD
index 709956eb0c8f..c307e2b1158b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
pkgname=stl-thumb
pkgver=0.4.0
-pkgrel=1
+pkgrel=2
license=('MIT')
pkgdesc="A fast lightweight thumbnail generator for STL files"
url='https://github.com/unlimitedbacon/stl-thumb'
-source=(git://github.com/unlimitedbacon/stl-thumb.git)
+source=(git+https://github.com/unlimitedbacon/stl-thumb.git)
depends=('libgl')
makedepends=("rust" "git")
arch=("i386" "x86_64")
@@ -16,6 +16,12 @@ build() {
cd "${srcdir}/${pkgname}"
git checkout tags/v${pkgver}
+
+ # Remove cargo config
+ # This file has gcc paths specifically for building on Debian/ARM
+ # Removing it allows this package to build on Arch Linux Arm
+ rm .cargo/config
+
cargo build --release
}