summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFernando Manfredi2018-06-28 20:46:15 -0300
committerFernando Manfredi2018-06-29 11:54:31 -0300
commit32e294fafb4564b2ccdf8e252209cd542cc5a7f7 (patch)
treecbf654acaee5df15405d5060ee7870145e50b0ce
downloadaur-32e294fafb4564b2ccdf8e252209cd542cc5a7f7.tar.gz
Initial package
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD38
-rw-r--r--depends.patch16
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72366b48df60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = stlib
+ pkgdesc = Async library that provides features related to Steam client and compatible stuffs
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://github.com/ShyPixie/stlib
+ arch = x86_64
+ license = GPL
+ makedepends = python-setuptools
+ makedepends = gcc
+ makedepends = unzip
+ depends = python>=3.6
+ depends = python-aiohttp
+ depends = python-beautifulsoup4
+ depends = python-rsa
+ optdepends = python-aiodns: For speeding up DNS resolving by WebAPI
+ optdepends = python-cchardet: For speeding up Character Encoding
+ source = https://github.com/ShyPixie/stlib/archive/v0.4.1.tar.gz
+ source = steamworks_sdk_142.zip::file://steamworks_sdk_142.zip
+ source = depends.patch
+ sha256sums = fa938adfee9d471f509a5c44c4a70f911238b4d4b0c23275e3098b8848063af6
+ sha256sums = 7695f8e183bef16dc2e663ffbdfad2248ae266bce8ff42066a3e88e1d54f0f42
+ sha256sums = 2a0644bc1ea14bc82facf36c57e43144b8ede344cf0ea03ba3a5375b34559eb9
+
+pkgname = stlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..452ecb30e228
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Acidhub <dev@acidhub.click>
+
+pkgname=stlib
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="Async library that provides features related to Steam client and compatible stuffs"
+arch=('x86_64')
+url="https://github.com/ShyPixie/stlib"
+depends=('python>=3.6' 'python-aiohttp' 'python-beautifulsoup4' 'python-rsa')
+optdepends=('python-aiodns: For speeding up DNS resolving by WebAPI'
+ 'python-cchardet: For speeding up Character Encoding')
+makedepends=('python-setuptools' 'gcc' 'unzip')
+license=('GPL')
+source=("https://github.com/ShyPixie/$pkgname/archive/v$pkgver.tar.gz"
+ 'steamworks_sdk_142.zip::file://steamworks_sdk_142.zip'
+ 'depends.patch')
+sha256sums=('fa938adfee9d471f509a5c44c4a70f911238b4d4b0c23275e3098b8848063af6'
+ '7695f8e183bef16dc2e663ffbdfad2248ae266bce8ff42066a3e88e1d54f0f42'
+ '2a0644bc1ea14bc82facf36c57e43144b8ede344cf0ea03ba3a5375b34559eb9')
+
+prepare() {
+ cp -R sdk/* "$pkgname-$pkgver/src/steam_api/steamworks_sdk/"
+ cd $pkgname-$pkgver
+ ls ../
+ patch -uN setup.py ../depends.patch || return 1
+}
+
+build() {
+ cd $pkgname-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $pkgname-$pkgver
+ python setup.py install --skip-build --optimize=1 --root="$pkgdir/"
+}
+
+
diff --git a/depends.patch b/depends.patch
new file mode 100644
index 000000000000..360c60ab7cea
--- /dev/null
+++ b/depends.patch
@@ -0,0 +1,16 @@
+--- setup.py.orig 2018-06-28 20:07:40.290566100 -0300
++++ setup.py 2018-06-28 20:07:50.203657200 -0300
+@@ -102,12 +102,9 @@
+ packages=['stlib'],
+ package_dir={'stlib': 'src'},
+ ext_modules=[steam_api],
+- requires=['aiodns',
+- 'aiohttp',
++ requires=['aiohttp',
+ 'asyncio',
+ 'beautifulsoup4',
+- 'cchardet',
+- 'ujson',
+ 'rsa',
+ ],
+ python_requires='>=3.6',