summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkumencz2023-01-20 18:28:52 +0100
committerkumencz2023-01-20 18:28:52 +0100
commit848b3d5d432620495c9a5395b07d09ade3f8da2b (patch)
tree69e244386f22ba6ceb7a3731770ef8e346b1e2c7
parent3f4ca1a151e4f3e2accc4091e4350748574c7743 (diff)
downloadaur-848b3d5d432620495c9a5395b07d09ade3f8da2b.tar.gz
PKGBUILD tweaks
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD37
2 files changed, 18 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f62bef54bc4e..ee94de48a8ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = stm32cubeide
pkgdesc = Integrated Development Environment for STM32
pkgver = 1.11.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.st.com/en/development-tools/stm32cubeide.html
arch = x86_64
license = Commercial
- makedepends = xdg-user-dirs
makedepends = imagemagick
depends = java-runtime
depends = glibc
@@ -16,10 +15,8 @@ pkgbase = stm32cubeide
optdepends = stlink
options = !strip
source = local://en.st-stm32cubeide_1.11.0_13638_20221122_1308_amd64.sh.zip
- source = 99-jlink.rules.patch
source = https://www.st.com/resource/en/license_agreement/dm00218346.pdf
sha256sums = 9bfd5402344607f4f307f24a6a2165a20342695e43d62edd0dd8c266c651a79a
- sha256sums = 0f3f69f7c980a701bf814e94595f5acb51a5d91be76b74e5b632220cfb0e7bb3
sha256sums = SKIP
pkgname = stm32cubeide
diff --git a/PKGBUILD b/PKGBUILD
index 8bf7929c4422..f066cd7dcda0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,10 +5,10 @@ pkgname="stm32cubeide"
pkgver=1.11.0
_pkgver_ext=1.11.0_13638_20221122_1308
_pkg_file_name=en.st-stm32cubeide_1.11.0_13638_20221122_1308_amd64.sh.zip
-pkgrel=1
+pkgrel=2
pkgdesc="Integrated Development Environment for STM32"
arch=("x86_64")
-makedepends=('xdg-user-dirs' 'imagemagick')
+makedepends=('imagemagick')
depends=('java-runtime' 'glibc' 'libusb' 'webkit2gtk' 'arm-none-eabi-gdb')
optdepends=('jlink-software-and-documentation' 'stlink')
conflicts=()
@@ -16,24 +16,19 @@ url="https://www.st.com/en/development-tools/stm32cubeide.html"
license=('Commercial')
options=(!strip)
-_DOWNLOADS_DIR=`xdg-user-dir DOWNLOAD`
if [ ! -f ${PWD}/${_pkg_file_name} ]; then
- if [ -f $_DOWNLOADS_DIR/${_pkg_file_name} ]; then
- ln -sfn $_DOWNLOADS_DIR/${_pkg_file_name} ${PWD}
- else
- msg2 ""
- msg2 "Package not found!"
- msg2 "The package can be downloaded here: ${url}"
- msg2 "Please remember to put a downloaded package ${_pkg_file_name} into the build directory ${PWD} or $_DOWNLOADS_DIR"
- msg2 ""
- fi
+ msg2 ""
+ msg2 "Package not found!"
+ msg2 "The ${pkgname} can be downloaded here: ${url}"
+ msg2 "Please remember to put a downloaded package ${_pkg_file_name} into the build directory before build here: ${PWD}"
+ msg2 ""
fi
source=("local://${_pkg_file_name}"
- "99-jlink.rules.patch"
+# "99-jlink.rules.patch"
"https://www.st.com/resource/en/license_agreement/dm00218346.pdf")
sha256sums=('9bfd5402344607f4f307f24a6a2165a20342695e43d62edd0dd8c266c651a79a'
- '0f3f69f7c980a701bf814e94595f5acb51a5d91be76b74e5b632220cfb0e7bb3'
+# '0f3f69f7c980a701bf814e94595f5acb51a5d91be76b74e5b632220cfb0e7bb3'
'SKIP')
prepare(){
@@ -63,18 +58,18 @@ package() {
chmod 0755 "${pkgdir}/usr/bin/stlink-server"
chown root:root "${pkgdir}/usr/bin/stlink-server"
- msg2 'Instalation of STlink udev rules skipped'
+ msg2 'Installation of STlink udev rules skipped'
#msg2 'Installing STlink udev rules'
#install -d -m755 "${pkgdir}/usr/lib/udev/rules.d/"
#install -D -o root -g root -m 644 -t "${pkgdir}/usr/lib/udev/rules.d/" "$srcdir/build/stlink-udev/fileset/"*.rules
- msg2 'Instalation of JLink udev rules skipped'
+ msg2 'Installation of JLink udev rules skipped'
#msg2 'Installing JLink udev rules'
#install -d -m755 "${pkgdir}/usr/lib/udev/rules.d/"
#install -D -o root -g root -m 644 -t "${pkgdir}/usr/lib/udev/rules.d/" "$srcdir/build/jlink-udev/"*.rules
#patch -i "${srcdir}/99-jlink.rules.patch" "${pkgdir}/usr/lib/udev/rules.d/99-jlink.rules"
- msg2 'Instalation of binary file'
+ msg2 'Installation of binary file'
install -Dm755 /dev/stdin "${pkgdir}/usr/bin/${pkgname}" <<END
#!/bin/sh
/opt/stm32cubeide/stm32cubeide "\$@"
@@ -88,13 +83,15 @@ END
Name=STM32CubeIDE
Comment=STM32CubeIDE 1.11.0
GenericName=STM32CubeIDE
-Exec=env GDK_BACKEND=x11 stm32cubeide %F
+#Exec=env GDK_BACKEND=x11 stm32cubeide %F
+#Exec=env WEBKIT_DISABLE_COMPOSITING_MODE=1 stm32cubeide %F
+Exec=stm32cubeide %F
Icon=stm32cubeide
Path=/opt/stm32cubeide/
Terminal=false
StartupNotify=true
Type=Application
-Categories=Development
+Categories=Development;IDE;Java;
END
msg2 'Replace GDB by system'
@@ -103,7 +100,7 @@ END
ln -s /usr/bin/arm-none-eabi-gdb "${pkgdir}/opt/stm32cubeide/plugins/"com.st.stm32cube.ide.mcu.externaltools.gnu-tools-for-stm32*/tools/bin
ln -s /usr/bin/arm-none-eabi-gdb-add-index "${pkgdir}/opt/stm32cubeide/plugins/"com.st.stm32cube.ide.mcu.externaltools.gnu-tools-for-stm32*/tools/bin
- msg2 'Instalation of license file'
+ msg2 'Installation of license file'
install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}/"
install -D -o root -g root -m 644 -t "${pkgdir}/usr/share/licenses/${pkgname}/" "${srcdir}/dm00218346.pdf"
}