summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun1232020-08-19 11:06:15 +0800
committeryjun1232020-08-19 11:06:15 +0800
commit39f9e0bbf0fca1cfc90fbf47a2690ff2ffc9d37a (patch)
treee0371fe894b85201599f936983188604c9420efc
downloadaur-39f9e0bbf0fca1cfc90fbf47a2690ff2ffc9d37a.tar.gz
initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD37
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02a20c6b5148
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = stm32cubemonitor
+ pkgdesc = graphical software for helping debug and diagnose STM32 applications while they are running by reading and displaying their variables in real-time
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://my.st.com/content/my_st_com/en/products/development-tools/software-development-tools/stm32-software-development-tools/stm32-performance-and-debuggers/stm32cubemonitor.html
+ arch = x86_64
+ license = custom
+ depends = gtk3
+ depends = nodejs
+ depends = nss
+ depends = libxss
+ depends = libnotify
+ depends = libxtst
+ depends = xdg-utils
+ depends = at-spi2-core
+ depends = libutil-linux
+ provides = stm32cubemonitor-bin
+ conflicts = stm32cubemonitor-bin
+ options = !strip
+ source = local://en.STM32CubeMonitor_lin.zip
+ sha256sums = d82c5282b8d3f64c68b58426bacd1b2139e3984bdb6df6262d3efa67712c9dfd
+
+pkgname = stm32cubemonitor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4556a43c4fc2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: yjun <jerrysteve1101@gmail.com>
+
+pkgname=stm32cubemonitor
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="graphical software for helping debug and diagnose STM32 applications while they are running by reading and displaying their variables in real-time"
+arch=('x86_64')
+url="https://my.st.com/content/my_st_com/en/products/development-tools/software-development-tools/stm32-software-development-tools/stm32-performance-and-debuggers/stm32cubemonitor.html"
+license=('custom')
+depends=('gtk3' 'nodejs' 'nss' 'libxss' 'libnotify' 'libxtst' 'xdg-utils' 'at-spi2-core' 'libutil-linux')
+provides=("${pkgname}-bin")
+conflicts=("${pkgname}-bin")
+options=('!strip')
+source=('local://en.STM32CubeMonitor_lin.zip')
+sha256sums=('d82c5282b8d3f64c68b58426bacd1b2139e3984bdb6df6262d3efa67712c9dfd')
+
+prepare() {
+ install -dm755 build
+ bsdtar -xf STM32CubeMonitor_lin/${pkgname}_${pkgver}_amd64.deb -C build
+}
+
+package() {
+ tar -xf build/data.tar.xz -C ${pkgdir}
+
+ install -dm755 ${pkgdir}/opt
+ mv ${pkgdir}/usr/lib/${pkgname} ${pkgdir}/opt
+ rm -rf ${pkgdir}/usr/lib
+ rm -rf ${pkgdir}/usr/share/lintian
+
+ # soft link
+ ln -fs /opt/${pkgname}/${pkgname} ${pkgdir}/usr/bin/${pkgname}
+
+ # license
+ install -Dm644 STM32CubeMonitor_lin/licenses/licenses_list_STM32CubeMonitor.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+# vim: set sw=2 ts=2 et: