summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun2022-03-16 12:50:12 +0800
committeryjun2022-03-16 12:50:12 +0800
commit8bcbb46b4defa3d6ad277920674ab7b7fc5159f6 (patch)
tree26028a23eac12ccd8459d531aa75986f8e8bbe88
parentbfca2b2cf403476dfa494789e6492e00744bc9d6 (diff)
downloadaur-8bcbb46b4defa3d6ad277920674ab7b7fc5159f6.tar.gz
[updpkg]: stm32cubemonitor 1.4.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e28a95d93c97..3841ca11e693 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = stm32cubemonitor
pkgdesc = Graphical software for helping debug and diagnose STM32 applications while they are running by reading and displaying their variables in real-time
- pkgver = 1.3.0
+ pkgver = 1.4.0
pkgrel = 1
url = https://www.st.com/en/development-tools/stm32cubemonitor.html
arch = x86_64
@@ -15,7 +15,7 @@ pkgbase = stm32cubemonitor
depends = util-linux-libs
depends = stlink
options = !strip
- source = en.STM32CubeMon-Lin-1.3.0.zip::https://www.st.com/content/ccc/resource/technical/software/sw_development_suite/group0/9e/83/1e/82/c0/42/49/38/STM32CubeMon-Lin/files/STM32CubeMon-Lin.zip/jcr:content/translations/en.STM32CubeMon-Lin.zip
- sha256sums = 8140a65873e986e552b2a24fbd17fb301a698e6e5f3fb3b1038fc51e4c30d014
+ source = en.STM32CubeMon-Lin_v1-4-0-1.4.0.zip::https://www.st.com/content/ccc/resource/technical/software/sw_development_suite/group0/b1/14/a0/74/6d/ac/4d/4c/STM32CubeMon-Lin_v1-4-0/files/STM32CubeMon-Lin_v1-4-0.zip/jcr:content/translations/en.STM32CubeMon-Lin_v1-4-0.zip
+ sha256sums = 3051deac09174cc5a906911c580e30c33f58d47707fdc536903ce27a42b5bc0f
pkgname = stm32cubemonitor
diff --git a/PKGBUILD b/PKGBUILD
index c2fd4976844f..edd83ae99866 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: yjun <jerrysteve1101@gmail.com>
+# Maintainer: yjun <jerrysteve1101 at gmail dot com>
pkgname=stm32cubemonitor
# _pkgname=STM32CubeMonitor
_pkgname=STM32CubeMon
-pkgver=1.3.0
+pkgver=1.4.0
pkgrel=1
pkgdesc="Graphical software for helping debug and diagnose STM32 applications while they are running by reading and displaying their variables in real-time"
arch=('x86_64')
@@ -12,12 +12,12 @@ license=('custom:SLA0048')
# package stlink provides stlink udev files
depends=('gtk3' 'nss' 'libxss' 'libnotify' 'libxtst' 'xdg-utils' 'at-spi2-core' 'util-linux-libs' 'stlink')
options=('!strip')
+_pkg_index_url="b1/14/a0/74/6d/ac/4d/4c"
# _pkg_file_name=${_pkgname}_lin_v${pkgver//./-}
-_pkg_file_name=${_pkgname}-Lin
-# https://www.st.com/content/st_com_cx/en/products/development-tools/software-development-tools/stm32-software-development-tools/stm32-performance-and-debuggers/stm32cubemonitor/_jcr_content/get-software/get-software-table-body.nocache.html/st-site-cx/components/containers/product/get-software-table-body.html
-_pkg_index_url="9e/83/1e/82/c0/42/49/38"
+# _pkg_file_name=${_pkgname}-Lin
+_pkg_file_name=${_pkgname}-Lin_v${pkgver//./-}
source=("en.${_pkg_file_name}-${pkgver}.zip::https://www.st.com/content/ccc/resource/technical/software/sw_development_suite/group0/${_pkg_index_url}/${_pkg_file_name}/files/${_pkg_file_name}.zip/jcr:content/translations/en.${_pkg_file_name}.zip")
-sha256sums=('8140a65873e986e552b2a24fbd17fb301a698e6e5f3fb3b1038fc51e4c30d014')
+sha256sums=('3051deac09174cc5a906911c580e30c33f58d47707fdc536903ce27a42b5bc0f')
# Extracted Files from ${_pkg_file_name}
# ├── driver
@@ -32,7 +32,8 @@ sha256sums=('8140a65873e986e552b2a24fbd17fb301a698e6e5f3fb3b1038fc51e4c30d014')
prepare() {
install -dm755 build
- bsdtar -xf ${pkgname}_${pkgver}_amd64.deb -C build
+
+ bsdtar -xf ${srcdir}/STM32CubeMonitor_lin/${pkgname}_${pkgver}_amd64.deb -C build
}
package() {
@@ -47,7 +48,7 @@ package() {
ln -fs /opt/${pkgname}/${pkgname} ${pkgdir}/usr/bin/${pkgname}
# license
- for _license in ${srcdir}/licenses/*
+ for _license in ${srcdir}/STM32CubeMonitor_lin/licenses/*
do
install -Dm644 "${_license}" -t ${pkgdir}/usr/share/licenses/${pkgname}/
done