summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun2021-10-10 11:08:07 +0800
committeryjun2021-10-10 11:08:07 +0800
commitbfca2b2cf403476dfa494789e6492e00744bc9d6 (patch)
tree7c9bd3992deb76e764b24cf4d44f795f13a18ff2
parent8a5c8f5abbb5d4bdae52712f21df929d11cc9dff (diff)
downloadaur-bfca2b2cf403476dfa494789e6492e00744bc9d6.tar.gz
updpkg: stm32cubemonitor 1.3.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e36622c6670..e28a95d93c97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = stm32cubemonitor
pkgdesc = Graphical software for helping debug and diagnose STM32 applications while they are running by reading and displaying their variables in real-time
- pkgver = 1.2.0
- pkgrel = 2
+ pkgver = 1.3.0
+ pkgrel = 1
url = https://www.st.com/en/development-tools/stm32cubemonitor.html
arch = x86_64
- license = SLA0048
+ license = custom:SLA0048
depends = gtk3
depends = nss
depends = libxss
@@ -15,7 +15,7 @@ pkgbase = stm32cubemonitor
depends = util-linux-libs
depends = stlink
options = !strip
- source = en.STM32CubeMonitor_lin_v1-2-0.zip::https://www.st.com/content/ccc/resource/technical/software/sw_development_suite/group0/70/4c/e0/01/b2/df/4c/45/STM32CubeMonitor_lin_v1-2-0/files/STM32CubeMonitor_lin_v1-2-0.zip/jcr:content/translations/en.STM32CubeMonitor_lin_v1-2-0.zip
- sha256sums = 89ca4051cea2e0dd115f9e5e1cb1344560fd408471d7a5caae1ca15cb736aa35
+ source = en.STM32CubeMon-Lin-1.3.0.zip::https://www.st.com/content/ccc/resource/technical/software/sw_development_suite/group0/9e/83/1e/82/c0/42/49/38/STM32CubeMon-Lin/files/STM32CubeMon-Lin.zip/jcr:content/translations/en.STM32CubeMon-Lin.zip
+ sha256sums = 8140a65873e986e552b2a24fbd17fb301a698e6e5f3fb3b1038fc51e4c30d014
pkgname = stm32cubemonitor
diff --git a/PKGBUILD b/PKGBUILD
index 646c0e117ac7..c2fd4976844f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,23 @@
# Maintainer: yjun <jerrysteve1101@gmail.com>
pkgname=stm32cubemonitor
-_pkgname=STM32CubeMonitor
-pkgver=1.2.0
-pkgrel=2
+# _pkgname=STM32CubeMonitor
+_pkgname=STM32CubeMon
+pkgver=1.3.0
+pkgrel=1
pkgdesc="Graphical software for helping debug and diagnose STM32 applications while they are running by reading and displaying their variables in real-time"
arch=('x86_64')
url="https://www.st.com/en/development-tools/stm32cubemonitor.html"
-license=('SLA0048')
+license=('custom:SLA0048')
# package stlink provides stlink udev files
depends=('gtk3' 'nss' 'libxss' 'libnotify' 'libxtst' 'xdg-utils' 'at-spi2-core' 'util-linux-libs' 'stlink')
options=('!strip')
-_pkg_file_name=${_pkgname}_lin_v${pkgver//./-}
+# _pkg_file_name=${_pkgname}_lin_v${pkgver//./-}
+_pkg_file_name=${_pkgname}-Lin
# https://www.st.com/content/st_com_cx/en/products/development-tools/software-development-tools/stm32-software-development-tools/stm32-performance-and-debuggers/stm32cubemonitor/_jcr_content/get-software/get-software-table-body.nocache.html/st-site-cx/components/containers/product/get-software-table-body.html
-source=("en.${_pkg_file_name}.zip::https://www.st.com/content/ccc/resource/technical/software/sw_development_suite/group0/70/4c/e0/01/b2/df/4c/45/${_pkg_file_name}/files/${_pkg_file_name}.zip/jcr:content/translations/en.${_pkg_file_name}.zip")
-sha256sums=('89ca4051cea2e0dd115f9e5e1cb1344560fd408471d7a5caae1ca15cb736aa35')
+_pkg_index_url="9e/83/1e/82/c0/42/49/38"
+source=("en.${_pkg_file_name}-${pkgver}.zip::https://www.st.com/content/ccc/resource/technical/software/sw_development_suite/group0/${_pkg_index_url}/${_pkg_file_name}/files/${_pkg_file_name}.zip/jcr:content/translations/en.${_pkg_file_name}.zip")
+sha256sums=('8140a65873e986e552b2a24fbd17fb301a698e6e5f3fb3b1038fc51e4c30d014')
# Extracted Files from ${_pkg_file_name}
# ├── driver