summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefano Marsili2019-06-15 13:36:16 +0200
committerStefano Marsili2019-06-15 13:36:16 +0200
commitbecc39d77df745e85f367d26b81f4976048717bd (patch)
treeda795670bd6f391085d3ed095a868a121f2b245d
downloadaur-becc39d77df745e85f367d26b81f4976048717bd.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..263c7848cbc9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = stmm-games
+ pkgdesc = C++ 2D games library
+ pkgver = 0.9
+ pkgrel = 1
+ url = https://www.efanomars.com/libraries/stmm-games
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = gcc
+ makedepends = doxygen
+ makedepends = graphviz
+ makedepends = python
+ depends = stmm-input
+ depends = gtkmm
+ depends = librsvg
+ depends = libxml++2.6
+ source = git+https://gitlab.com/efanomars/stmm-games.git#commit=155a45b90bd9a02b67ca4a9ec95529286e56cec1
+ sha512sums = SKIP
+
+pkgname = stmm-games
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e767d9c91b48
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Stefano Marsili <efanomars@gmx.ch>
+
+pkgname=stmm-games
+pkgver=0.9
+pkgrel=1
+pkgdesc="C++ 2D games library"
+url='https://www.efanomars.com/libraries/stmm-games'
+arch=('x86_64')
+license=('GPL3')
+
+depends=('stmm-input' 'gtkmm' 'librsvg' 'libxml++2.6')
+makedepends=('cmake' 'gcc' 'doxygen' 'graphviz' 'python')
+optdepends=()
+
+#provides=("stmm-games")
+#replaces=("stmm-games")
+#conflicts=("stmm-games")
+
+source=('git+https://gitlab.com/efanomars/stmm-games.git#commit=155a45b90bd9a02b67ca4a9ec95529286e56cec1')
+sha512sums=('SKIP')
+
+build() {
+ cd "${srcdir}/stmm-games"
+
+ ./scripts/install_stmm-games-all.py -b=Release -s=Off -t=Off -d=Off --installdir="/usr" --no-install --no-sudo
+}
+
+package() {
+ cd "${srcdir}/stmm-games"
+
+ ./scripts/priv/dd_install_stmm-games-all.py -b=Release -s=Off -t=Off -d=Off --installdir="/usr" --destdir="${pkgdir}" --no-configure --no-make --no-sudo
+}