summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefano Marsili2019-08-16 21:11:56 +0200
committerStefano Marsili2019-08-16 21:11:56 +0200
commite81bfc253bc0d91e87b109b7333b4c7de841a8a3 (patch)
tree9783daa15934cd0881544e1a8860c5f055322629
parent7e2c1e872b594ecdf5e6576d89000cd16389374e (diff)
downloadaur-e81bfc253bc0d91e87b109b7333b4c7de841a8a3.tar.gz
New release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
2 files changed, 21 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c5b467b90fa..3dbf0dca0fed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = stmm-input-bt
pkgdesc = Device input event library - keyboards over bluetooth
- pkgver = 0.5
+ pkgver = 0.6
pkgrel = 1
url = https://www.efanomars.com/libraries/stmm-input-bt
arch = x86_64
@@ -13,8 +13,8 @@ pkgbase = stmm-input-bt
depends = stmm-input
depends = bluez
depends = gtkmm
- depends = gconfmm
- source = git+https://gitlab.com/efanomars/stmm-input-bt.git#commit=6abf72ed0f124ce62e92f7b5752c9d3b8fdb68fc
+ depends = dconf
+ source = git+https://gitlab.com/efanomars/stmm-input-bt.git#commit=e426fd2610acf8a007f4197dea30de5305a5885d
sha512sums = SKIP
pkgname = stmm-input-bt
diff --git a/PKGBUILD b/PKGBUILD
index 6ce19c519efc..9b502c042ba0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Stefano Marsili <efanomars@gmx.ch>
pkgname=stmm-input-bt
-pkgver=0.5
+pkgver=0.6
pkgrel=1
pkgdesc="Device input event library - keyboards over bluetooth"
url='https://www.efanomars.com/libraries/stmm-input-bt'
arch=('x86_64')
license=('GPL3','LGPL3')
-depends=('stmm-input' 'bluez' 'gtkmm' 'gconfmm')
+depends=('stmm-input' 'bluez' 'gtkmm' 'dconf')
makedepends=('cmake' 'gcc' 'doxygen' 'graphviz' 'python')
optdepends=()
@@ -16,17 +16,30 @@ optdepends=()
#replaces=("stmm-input-bt")
#conflicts=("stmm-input-bt")
-source=('git+https://gitlab.com/efanomars/stmm-input-bt.git#commit=6abf72ed0f124ce62e92f7b5752c9d3b8fdb68fc')
+source=('git+https://gitlab.com/efanomars/stmm-input-bt.git#commit=e426fd2610acf8a007f4197dea30de5305a5885d')
sha512sums=('SKIP')
build() {
cd "${srcdir}/stmm-input-bt"
- ./scripts/install_stmm-input-bt-all.py -b=Release -s=Off -t=Off -d=Off --installdir="/usr" --no-install --no-sudo
+ ./scripts/install_stmm-input-bt-all.py -b=Release -s=Off -t=Off -d=Off --installdir="/usr" --no-install --no-compile-schemas --no-sudo
}
package() {
cd "${srcdir}/stmm-input-bt"
- ./scripts/priv/dd_install_stmm-input-bt-all.py -b=Release -s=Off -t=Off -d=Off --installdir="/usr" --destdir="${pkgdir}" --no-configure --no-make --no-sudo
+ ./scripts/priv/dd_install_stmm-input-bt-all.py -b=Release -s=Off -t=Off -d=Off --installdir="/usr" --destdir="${pkgdir}" --no-configure --no-make --no-compile-schemas --no-sudo
}
+
+post_install() {
+ glib-compile-schemas "/usr/share/glib-2.0/schemas"
+}
+
+post_upgrade() {
+ glib-compile-schemas "/usr/share/glib-2.0/schemas"
+}
+
+post_remove() {
+ glib-compile-schemas "/usr/share/glib-2.0/schemas"
+}
+