summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Epplee2020-12-16 13:38:45 +0100
committerRafael Epplee2020-12-16 13:38:45 +0100
commite238af2da1e793e017dae004e8759f5938dbcd6f (patch)
tree03928e0d76ac459aa0b9a9978a09b79c99811e21
downloadaur-e238af2da1e793e017dae004e8759f5938dbcd6f.tar.gz
add initial pkgbuild for version 0.0.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0e64f908685
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = stmp
+ pkgdesc = Subsonic Terminal Music Player
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/wildeyedskies/stmp
+ arch = x86_64
+ license = GPL
+ makedepends = go
+ depends = mpv
+ source = stmp-0.0.1.tar.gz::https://github.com/wildeyedskies/stmp/archive/0.0.1.tar.gz
+ sha256sums = 0a304184a51127ad4cc6dffed56168e105d1b6a15cb347184bfb3db2ad1170c6
+
+pkgname = stmp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd1689b2bf1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Rafael Epplée <aur@rafa.ee>
+pkgname=stmp
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Subsonic Terminal Music Player"
+arch=('x86_64')
+url="https://github.com/wildeyedskies/stmp"
+license=('GPL')
+depends=('mpv')
+makedepends=('go')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/wildeyedskies/stmp/archive/${pkgver}.tar.gz")
+sha256sums=('0a304184a51127ad4cc6dffed56168e105d1b6a15cb347184bfb3db2ad1170c6')
+
+build() {
+ export GOPATH="$srcdir"/gopath
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw -gcflags=all=-trimpath=${PWD}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_ENABLED=1
+
+ cd "$srcdir/$pkgname-$pkgver"
+
+ go get -d
+ go build -a \
+ -ldflags "-linkmode external -extldflags \"${LDFLAGS}\"" \
+ .
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 "$pkgname-$pkgver" "$pkgdir/usr/bin/stmp"
+}
+