summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroguzkurt2018-02-01 11:25:20 +0300
committeroguzkurt2018-02-01 11:25:20 +0300
commitff2c3d658d2b9fc6db92fed5c166187260f5113a (patch)
tree388a0ef283d621fe65a32da28451c6d793c70242
downloadaur-stock-shares.tar.gz
first release
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33931ecdd94e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = stock-shares
+ pkgdesc = A cli utility that gets stock information from bloomberg.
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/oguzkurt182/stock-shares
+ arch = any
+ license = GPL
+ makedepends = make
+ depends = python
+ depends = python-beautifulsoup4
+ source = https://github.com/oguzkurt182/stock-shares/archive/master.zip
+
+pkgname = stock-shares
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37d0b33630a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Oguz Kurt <kurt.oguz@outlook.com>
+pkgname=stock-shares
+pkgver=1
+pkgrel=1
+pkgdesc="A cli utility that gets stock information from bloomberg."
+arch=('any')
+url="https://github.com/oguzkurt182/stock-shares"
+license=('GPL')
+depends=('sh')
+depends=('python-beautifulsoup4')
+depends=('python')
+makedepends=('make')
+source=("https://github.com/oguzkurt182/stock-shares/archive/master.zip")
+
+package() {
+ cd "$pkgname-master"
+ make DESTDIR="$pkgdir/" install
+}