summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBoohbah2015-07-06 21:29:52 +0000
committerBoohbah2015-07-06 21:29:52 +0000
commit1586c5ea5c6f63c0becde317a317afba59b1e6e5 (patch)
treea1594d48fddf335598dd493543191da6dc6c575f
downloadaur-1586c5ea5c6f63c0becde317a317afba59b1e6e5.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
-rw-r--r--stockfish.install10
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a19b4b303d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = stockfish-git
+ pkgdesc = A free UCI chess engine derived from Glaurung 2.1 (git version)
+ pkgver = r3393.gfe07ae4
+ pkgrel = 1
+ url = http://stockfishchess.org/
+ install = stockfish.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ optdepends = polyglot: for xboard support
+ provides = stockfish
+ conflicts = stockfish
+ source = stockfish-git::git+https://github.com/official-stockfish/Stockfish.git
+ md5sums = SKIP
+
+pkgname = stockfish-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a42fba6246fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Boohbah <boohbah at gmail dot com>
+# Contributor: P. Badredin <p dot badredin at gmail dot com>
+# Contributor: Justin Blanchard <UncombedCoconut at gmail dot com>
+
+pkgname=stockfish-git
+pkgver=r3393.gfe07ae4
+pkgrel=1
+pkgdesc="A free UCI chess engine derived from Glaurung 2.1 (git version)"
+arch=('i686' 'x86_64')
+url="http://stockfishchess.org/"
+license=('GPL3')
+optdepends=('polyglot: for xboard support')
+makedepends=('git')
+provides=('stockfish')
+conflicts=('stockfish')
+install=stockfish.install
+source=("$pkgname::git+https://github.com/official-stockfish/Stockfish.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname/src"
+ if [[ "$CARCH" == "i686" ]]; then
+ _arch=x86-32
+ elif grep -q popcnt /proc/cpuinfo; then
+ _arch=x86-64-modern
+ else
+ _arch=x86-64
+ fi
+ make profile-build ARCH=$_arch
+}
+
+package() {
+ cd "$pkgname/src"
+ make PREFIX="$pkgdir/usr" install
+}
+
+# vim:set sts=2 sw=2 et:
diff --git a/stockfish.install b/stockfish.install
new file mode 100644
index 000000000000..0f2a13873a9b
--- /dev/null
+++ b/stockfish.install
@@ -0,0 +1,10 @@
+post_install() {
+cat << EOM
+
+ ==>
+ ==> Official builds using the Intel compiler are likely to be stronger.
+ ==>
+
+EOM
+}
+