summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2022-07-08 21:53:30 +0000
committerFlorian Hülsmann2022-07-08 21:53:30 +0000
commit00553156b977ff62bccab55aeb7f0283a02889f1 (patch)
tree2b776e6e699833ba711f11b5428db10cf27aa8cd
parent7988a16f14917fffe95186fb7867730a615e04c1 (diff)
downloadaur-00553156b977ff62bccab55aeb7f0283a02889f1.tar.gz
bump some pkgrels to trigger AUR updates and debug builds (#89)
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD55
3 files changed, 53 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 526e60cb2e0c..8cbc446976d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,26 @@
pkgbase = stone-phaser
pkgdesc = A classic analog phaser effect LADSPA, LV2 and VST2 plugin
pkgver = 0.1.2
- pkgrel = 1
+ pkgrel = 3
url = https://github.com/jpcima/stone-phaser
- arch = i686
arch = x86_64
- groups = pro-audio
+ arch = aarch64
groups = ladspa-plugins
groups = lv2-plugins
+ groups = pro-audio
groups = vst-plugins
license = Boost
- makedepends = mesa
+ checkdepends = lv2lint
+ makedepends = libglvnd
depends = cairo
+ depends = glibc
+ depends = gcc-libs
+ optdepends = ladspa-host: for LADSPA plugin
+ optdepends = lv2-host: for LV2 plugin
+ optdepends = vst-host: for VST plugin
source = https://github.com/jpcima/stone-phaser/releases/download/v0.1.2/stone-phaser-0.1.2.tar.gz
+ source = stone-phaser-Makefile.base.mk::https://raw.githubusercontent.com/DISTRHO/DPF/05d91f5852f4bccfd2bce1d4d2e2b3036e29db03/Makefile.base.mk
sha256sums = cd19c588469125e4aff3add2a570b4b2d9dc98ef37ccc2785636a0b52df86ddf
+ sha256sums = ef890c65422c8c73ffea7687a45317689378ff2b0f3ccadd497ca1cdc77e08a4
pkgname = stone-phaser
-
diff --git a/.gitignore b/.gitignore
index ce0fa38edc67..6a7b59b4f9b2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,5 @@
+stone-phaser-Makefile.base.mk
pkg/
src/
-stone-phaser-*.tar.gz
-stone-phaser-*.tar.xz
-stone-phaser-*.src.tar.gz
-.AURINFO
-DPF-bypass.patch
+*.tar.*
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
index 69c5213f9d75..582874e71704 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,52 @@
-# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Maintainer: OSAMC <https://github.com/osam-cologne/archlinux-proaudio>
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
pkgname=stone-phaser
+_plugin_uri="http://jpcima.sdf1.org/lv2/$pkgname"
pkgver=0.1.2
-pkgrel=1
-pkgdesc="A classic analog phaser effect LADSPA, LV2 and VST2 plugin"
-arch=('i686' 'x86_64')
-url="https://github.com/jpcima/stone-phaser"
-license=('Boost')
-depends=('cairo')
-makedepends=('mesa')
-#optdepends=('mod-ui: for using the MOD pedal GUI')
-groups=('pro-audio' 'ladspa-plugins' 'lv2-plugins' 'vst-plugins')
-source=("https://github.com/jpcima/stone-phaser/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('cd19c588469125e4aff3add2a570b4b2d9dc98ef37ccc2785636a0b52df86ddf')
-
+pkgrel=3
+pkgdesc='A classic analog phaser effect LADSPA, LV2 and VST2 plugin'
+arch=(x86_64 aarch64)
+url='https://github.com/jpcima/stone-phaser'
+license=(Boost)
+depends=(cairo glibc gcc-libs)
+makedepends=(libglvnd)
+checkdepends=(lv2lint)
+optdepends=(
+ 'ladspa-host: for LADSPA plugin'
+ 'lv2-host: for LV2 plugin'
+ 'vst-host: for VST plugin'
+)
+groups=(ladspa-plugins lv2-plugins pro-audio vst-plugins)
+_dpf_commit='05d91f5852f4bccfd2bce1d4d2e2b3036e29db03'
+source=("https://github.com/jpcima/stone-phaser/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ "${pkgname}-Makefile.base.mk::https://raw.githubusercontent.com/DISTRHO/DPF/$_dpf_commit/Makefile.base.mk")
+sha256sums=('cd19c588469125e4aff3add2a570b4b2d9dc98ef37ccc2785636a0b52df86ddf'
+ 'ef890c65422c8c73ffea7687a45317689378ff2b0f3ccadd497ca1cdc77e08a4')
prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}/dpf"
+ cd $pkgname-$pkgver/dpf
patch -N -r - -p 1 -i ../resources/patch/DPF-bypass.patch
+ cd ..
+ # Update DPF base makefile to fix arm64 build
+ cp -f "$srcdir"/$pkgname-Makefile.base.mk dpf/Makefile.base.mk
}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd $pkgname-$pkgver
make
}
+check() {
+ cd $pkgname-$pkgver
+ lv2lint -Mpack -q \
+ -s lv2_generate_ttl \
+ -t "Plugin Author Email" \
+ -t "UI Idle Interface" \
+ -I "bin/$pkgname.lv2/" "$_plugin_uri"
+}
+
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" PREFIX=/usr install
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" PREFIX=/usr install
}