summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Moynihan2020-05-19 12:21:09 +0100
committerEric Moynihan2020-05-19 12:21:09 +0100
commitd66a283bc1ade164b68fd43f01f42215f081872f (patch)
treece27184f4ac7596e9ec20b65b3c08944b754e12d
downloadaur-d66a283bc1ade164b68fd43f01f42215f081872f.tar.gz
Release 1.0.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba194c454620
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = stonks
+ pkgdesc = Stonks is a terminal based stock visualizer and tracker that displays realtime stocks in graph format in a terminal. See how fast your stonks will crash.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/ericm/stonks
+ arch = any
+ license = GPL3
+ makedepends = go>=1.12
+ makedepends = make
+ makedepends = pkgconf
+ source = stonks::git+https://github.com/ericm/stonks.git#tag=v1.0.0
+ sha256sums = SKIP
+
+pkgname = stonks
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0832df04a8dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=stonks
+_pkgname=stonks
+pkgver="1.0.0"
+_pkgver="1.0.0"
+pkgrel=1
+pkgdesc="Stonks is a terminal based stock visualizer and tracker that displays realtime stocks in graph format in a terminal. See how fast your stonks will crash."
+arch=('any')
+url="https://github.com/ericm/stonks"
+license=('GPL3')
+source=("${_pkgname}::git+https://github.com/ericm/stonks.git#tag=v${_pkgver}")
+sha256sums=('SKIP')
+
+makedepends=('go>=1.12' 'make' 'pkgconf')
+
+prepare() {
+ cd "${_pkgname}"
+ make
+}
+
+package() {
+ install -dm755 ${pkgdir}/usr/local/bin/${BINAME}
+ cd "${_pkgname}"
+ cp ${_pkgname} ${pkgdir}/usr/local/bin/${BINAME}
+}