summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhanibek Adilbekov2017-04-19 08:24:13 +0600
committerZhanibek Adilbekov2017-04-19 08:24:13 +0600
commit6f5a9714b3dd9bdb0c97d41fcf25c5c897f1eaf2 (patch)
tree01147723fcc7dc050ab898ada8b962b643b91212
downloadaur-6f5a9714b3dd9bdb0c97d41fcf25c5c897f1eaf2.tar.gz
Initial commmit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD27
-rw-r--r--stoplight-desktop-bin.install13
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f649fd909a42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = stoplight-desktop-bin
+ pkgdesc = The Stoplight desktop app.
+ pkgver = 3.1.1
+ pkgrel = 1
+ url = https://stoplight.io/platform/scenarios/
+ install = stoplight-desktop-bin.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = libxss
+ depends = libappindicator-gtk2
+ provides = stoplight-desktop-bin
+ options = !emptydirs
+ options = !strip
+ source_i686 = https://github.com/stoplightio/desktop/releases/download/v3.1.1/Scenarios_3.1.1_i386.deb
+ sha256sums_i686 = 67361cd78d56da9437658cff400274e77fe7e95e08d36403749bfa06849bbfe5
+ source_x86_64 = https://github.com/stoplightio/desktop/releases/download/v3.1.1/Scenarios_3.1.1_amd64.deb
+ sha256sums_x86_64 = e38461afc06daf0b6a950b8e7d8487122ca1e99130b31f07683833887cfd4414
+
+pkgname = stoplight-desktop-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a60a2e1bca74
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Zhanibek Adilbekov <zhanibek@archlinux.info>
+pkgname=stoplight-desktop-bin
+pkgver=3.1.1
+pkgrel=1
+pkgdesc="The Stoplight desktop app."
+arch=('i686' 'x86_64')
+url="https://stoplight.io/platform/scenarios/"
+license=('unknown')
+depends=('libxss' 'libappindicator-gtk2')
+optdepends=()
+provides=('stoplight-desktop-bin')
+conflicts=()
+options=('!emptydirs' '!strip')
+install=${pkgname}.install
+source_i686=("https://github.com/stoplightio/desktop/releases/download/v${pkgver}/Scenarios_${pkgver}_i386.deb")
+source_x86_64=("https://github.com/stoplightio/desktop/releases/download/v${pkgver}/Scenarios_${pkgver}_amd64.deb")
+sha256sums_i686=('67361cd78d56da9437658cff400274e77fe7e95e08d36403749bfa06849bbfe5')
+sha256sums_x86_64=('e38461afc06daf0b6a950b8e7d8487122ca1e99130b31f07683833887cfd4414')
+
+package() {
+ cd "${pkgdir}"
+ for I in `ls "${srcdir}" | grep '\.deb$'`; do
+ ar x "${srcdir}/$I" data.tar.xz
+ tar -xf data.tar.xz
+ rm "${pkgdir}/data.tar.xz"
+ done
+}
diff --git a/stoplight-desktop-bin.install b/stoplight-desktop-bin.install
new file mode 100644
index 000000000000..c49699a6d935
--- /dev/null
+++ b/stoplight-desktop-bin.install
@@ -0,0 +1,13 @@
+post_install() {
+ ln -sf /opt/Scenarios/scenarios /usr/bin/scenarios
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ rm -f /usr/bin/scenarios
+ update-desktop-database -q
+}