summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Grimes2012-09-04 09:11:10 -0400
committerMark Grimes2012-09-04 09:11:10 -0400
commit05c4d4d0d986360cbe09d14264d5124b95fb1d71 (patch)
tree125d5f5efb95d3319809cd0de87d2bac62d64772
parentf1277c996b9bb146f1144e712e8edfde31a1b051 (diff)
downloadaur-05c4d4d0d986360cbe09d14264d5124b95fb1d71.tar.gz
Fixes bug caused by the removal of includes in gcc std libs
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
-rw-r--r--add-unistd.patch45
3 files changed, 55 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 814b4d6503c1..40e7db5e215a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,23 @@
pkgbase = stopmotion
pkgdesc = Stop motion animation creation program
pkgver = 0.6.2
- pkgrel = 2
+ pkgrel = 3
url = http://stopmotion.bjoernen.com
arch = i686
arch = x86_64
license = GPL
makedepends = pkgconfig
depends = qt
- depends = libtar
depends = sdl_image
depends = libxml2
depends = libvorbis
- depends = fam
depends = inotify-tools
- depends = libx11
source = http://developer.skolelinux.no/info/studentgrupper/2005-hig-stopmotion/project_management/webpage/releases/stopmotion-0.6.2.tar.gz
source = add-x11-lib.patch
+ source = add-unistd.patch
md5sums = a139f036286f31bba21effb2b6553d1e
md5sums = e8943488fec6994aee11ac9f25d04d45
+ md5sums = 87bbc308a7c3146560fd3cf1dc7ceb78
pkgname = stopmotion
diff --git a/PKGBUILD b/PKGBUILD
index 03a4831abf89..7e3fc1251d3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,17 @@
pkgname=stopmotion
pkgver=0.6.2
-pkgrel=2
+pkgrel=3
arch=('i686' 'x86_64')
pkgdesc="Stop motion animation creation program"
url="http://stopmotion.bjoernen.com"
license=('GPL')
makedepends=('pkgconfig')
-depends=('qt' 'libtar' 'sdl_image' 'libxml2' 'libvorbis' 'fam' 'inotify-tools'
- 'libx11')
+depends=('qt' 'sdl_image' 'libxml2' 'libvorbis' 'inotify-tools')
source=(http://developer.skolelinux.no/info/studentgrupper/2005-hig-stopmotion/project_management/webpage/releases/$pkgname-$pkgver.tar.gz
- add-x11-lib.patch)
-md5sums=('a139f036286f31bba21effb2b6553d1e'
- 'e8943488fec6994aee11ac9f25d04d45')
+ add-x11-lib.patch add-unistd.patch)
+md5sums=('a139f036286f31bba21effb2b6553d1e' 'e8943488fec6994aee11ac9f25d04d45'
+ '87bbc308a7c3146560fd3cf1dc7ceb78' )
_qt4profile=/etc/profile.d/qt4.sh
@@ -23,6 +22,8 @@ build() {
cd "$srcdir/$pkgname-$pkgver"
patch -p1 < "${srcdir}/add-x11-lib.patch"
+ patch -p1 < "${srcdir}/add-unistd.patch"
+
./configure --prefix=/usr --with-html-dir=/usr/share/$pkgname/html
make -j1
}
diff --git a/add-unistd.patch b/add-unistd.patch
new file mode 100644
index 000000000000..e8fd988522b2
--- /dev/null
+++ b/add-unistd.patch
@@ -0,0 +1,45 @@
+diff -aur stopmotion-0.6.2.orig/src/application/externalchangemonitor.cpp stopmotion-0.6.2/src/application/externalchangemonitor.cpp
+--- stopmotion-0.6.2.orig/src/application/externalchangemonitor.cpp 2008-07-25 06:59:03.000000000 -0400
++++ stopmotion-0.6.2/src/application/externalchangemonitor.cpp 2012-09-04 08:53:30.698395845 -0400
+@@ -27,6 +27,8 @@
+ #include <inotifytools/inotifytools.h>
+ #include <inotifytools/inotify.h>
+
++#include <unistd.h>
++
+ /**
+ * @todo uniform most of the getenv("home") calls so that it is done once
+ * and pasted around.
+diff -aur stopmotion-0.6.2.orig/src/domain/animation/scene.cpp stopmotion-0.6.2/src/domain/animation/scene.cpp
+--- stopmotion-0.6.2.orig/src/domain/animation/scene.cpp 2008-07-25 06:59:03.000000000 -0400
++++ stopmotion-0.6.2/src/domain/animation/scene.cpp 2012-09-04 08:53:30.841727919 -0400
+@@ -20,6 +20,7 @@
+ #include "scene.h"
+ #include <sstream>
+ #include <cstring>
++#include <unistd.h>
+
+ Scene::Scene()
+ {
+diff -aur stopmotion-0.6.2.orig/src/presentation/frontends/qtfrontend/mainwindowgui.cpp stopmotion-0.6.2/src/presentation/frontends/qtfrontend/mainwindowgui.cpp
+--- stopmotion-0.6.2.orig/src/presentation/frontends/qtfrontend/mainwindowgui.cpp 2008-07-25 06:59:03.000000000 -0400
++++ stopmotion-0.6.2/src/presentation/frontends/qtfrontend/mainwindowgui.cpp 2012-09-04 08:53:30.951727867 -0400
+@@ -45,6 +45,7 @@
+
+ #include <cstdlib>
+ #include <iostream>
++#include <unistd.h>
+
+ using namespace std;
+ using namespace Qt;
+diff -aur stopmotion-0.6.2.orig/src/technical/projectserializer.cpp stopmotion-0.6.2/src/technical/projectserializer.cpp
+--- stopmotion-0.6.2.orig/src/technical/projectserializer.cpp 2008-07-25 06:59:03.000000000 -0400
++++ stopmotion-0.6.2/src/technical/projectserializer.cpp 2012-09-04 08:53:31.068394471 -0400
+@@ -28,6 +28,7 @@
+ #include <libgen.h>
+ #include <stdlib.h>
+ #include <cstring>
++#include <unistd.h>
+
+ const char ProjectSerializer::imageDirectory[] = "images/";
+ const char ProjectSerializer::soundDirectory[] = "sounds/";