summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Grimes2014-07-10 14:04:52 -0400
committerMark Grimes2014-07-10 14:04:52 -0400
commita8cc45da403e4129c50b81e49cc5e69685a9d0fa (patch)
tree1bd8bccf2a985de361b6aa758b4483dde6737a15
parent05c4d4d0d986360cbe09d14264d5124b95fb1d71 (diff)
downloadaur-a8cc45da403e4129c50b81e49cc5e69685a9d0fa.tar.gz
Migrates to git tags
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD55
-rw-r--r--README4
-rw-r--r--add-unistd.patch45
-rw-r--r--add-x11-lib.patch11
6 files changed, 38 insertions, 99 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40e7db5e215a..42c702091ac8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,20 @@
pkgbase = stopmotion
pkgdesc = Stop motion animation creation program
- pkgver = 0.6.2
- pkgrel = 3
- url = http://stopmotion.bjoernen.com
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = http://linuxstopmotion.org/index.html
arch = i686
arch = x86_64
license = GPL
- makedepends = pkgconfig
- depends = qt
+ makedepends = git
+ makedepends = libtar
+ depends = qt4
depends = sdl_image
depends = libxml2
depends = libvorbis
- depends = inotify-tools
- source = http://developer.skolelinux.no/info/studentgrupper/2005-hig-stopmotion/project_management/webpage/releases/stopmotion-0.6.2.tar.gz
- source = add-x11-lib.patch
- source = add-unistd.patch
- md5sums = a139f036286f31bba21effb2b6553d1e
- md5sums = e8943488fec6994aee11ac9f25d04d45
- md5sums = 87bbc308a7c3146560fd3cf1dc7ceb78
+ conflicts = linuxstopmotion-git
+ source = linuxstopmotion::git+http://git.code.sf.net/p/linuxstopmotion/code#tag=0.8.0
+ md5sums = SKIP
pkgname = stopmotion
diff --git a/.gitignore b/.gitignore
index 3a9d0bc28990..cad182fe4761 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@ src/
stopmotion-*.pkg.tar.xz
stopmotion-*.src.tar.gz
stopmotion-*.tar.gz
+linuxstopmotion
diff --git a/PKGBUILD b/PKGBUILD
index 7e3fc1251d3b..631350c23aca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,40 @@
# Contributor: Mark Grimes <mark_aur@peculier.com>
# Contributor: Tom Vincent <http://tlvince.com/contact/>
+# Contributor: macxcool
pkgname=stopmotion
-pkgver=0.6.2
-pkgrel=3
+_realname=linuxstopmotion
+pkgver=0.8.0
+pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Stop motion animation creation program"
-url="http://stopmotion.bjoernen.com"
+url="http://linuxstopmotion.org/index.html"
license=('GPL')
makedepends=('pkgconfig')
-depends=('qt' 'sdl_image' 'libxml2' 'libvorbis' 'inotify-tools')
-source=(http://developer.skolelinux.no/info/studentgrupper/2005-hig-stopmotion/project_management/webpage/releases/$pkgname-$pkgver.tar.gz
- add-x11-lib.patch add-unistd.patch)
-md5sums=('a139f036286f31bba21effb2b6553d1e' 'e8943488fec6994aee11ac9f25d04d45'
- '87bbc308a7c3146560fd3cf1dc7ceb78' )
-
-_qt4profile=/etc/profile.d/qt4.sh
+depends=('qt4' 'sdl_image' 'libxml2' 'libvorbis')
+# 'inotify-tools'
+makedepends=('git' 'libtar')
+conflicts=('linuxstopmotion-git')
+source=($_realname::git+http://git.code.sf.net/p/$_realname/code#tag=$pkgver)
+# add-unistd.patch)
+md5sums=('SKIP')
build() {
- [ -e $_qt4profile ] && . $_qt4profile
- cd "$srcdir/$pkgname-$pkgver"
-
- patch -p1 < "${srcdir}/add-x11-lib.patch"
- patch -p1 < "${srcdir}/add-unistd.patch"
-
- ./configure --prefix=/usr --with-html-dir=/usr/share/$pkgname/html
- make -j1
-}
-
-check() {
- cd "$srcdir/$pkgname-$pkgver"
- make -k check
+ cd "$srcdir/$_realname"
+ lrelease-qt4 stopmotion.pro
+ qmake-qt4 PREFIX=/usr stopmotion.pro
+ sed -i '/^LIBS/s|$| -lX11|' Makefile
+ make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make prefix=$startdir/pkg install
-
- # Makefile doesn't seem to install the man file
- gzip ${pkgname}.1
- mkdir -p $startdir/pkg/usr/share/man/man1
- install -m 644 -p ${pkgname}.1.gz $startdir/pkg/usr/share/man/man1
+ cd "$srcdir/$_realname"
+ sed -e 's/install_desktop install_dummy/install_desktop/' -i Makefile.Release
+ make INSTALL_ROOT="$pkgdir" install
+ install -D -m644 stopmotion.desktop "$pkgdir"/usr/share/applications/stopmotion.desktop
+ install -D -m644 graphics/stopmotion.png "$pkgdir"/usr/share/pixmaps/stopmotion.png
+ install -D -m644 stopmotion.mime "$pkgdir"/usr/share/mime-info/stopmotion.mime
+ install -D -m644 stopmotion.1 "$pkgdir"/usr/share/man/man1/stopmotion.1
+ gzip "$pkgdir"/usr/share/man/man1/stopmotion.1
}
diff --git a/README b/README
index 0003c10f12ad..99f9ec5cbaa1 100644
--- a/README
+++ b/README
@@ -5,5 +5,7 @@ users will be able to create stop-motions from pictures imported from a camera
or from the harddrive, add sound effects and export the animation to different
video formats such as mpeg or avi.
- http://stopmotion.bjoernen.com/
+ http://linuxstopmotion.org/
+
+ (originally http://stopmotion.bjoernen.com/)
diff --git a/add-unistd.patch b/add-unistd.patch
deleted file mode 100644
index e8fd988522b2..000000000000
--- a/add-unistd.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff -aur stopmotion-0.6.2.orig/src/application/externalchangemonitor.cpp stopmotion-0.6.2/src/application/externalchangemonitor.cpp
---- stopmotion-0.6.2.orig/src/application/externalchangemonitor.cpp 2008-07-25 06:59:03.000000000 -0400
-+++ stopmotion-0.6.2/src/application/externalchangemonitor.cpp 2012-09-04 08:53:30.698395845 -0400
-@@ -27,6 +27,8 @@
- #include <inotifytools/inotifytools.h>
- #include <inotifytools/inotify.h>
-
-+#include <unistd.h>
-+
- /**
- * @todo uniform most of the getenv("home") calls so that it is done once
- * and pasted around.
-diff -aur stopmotion-0.6.2.orig/src/domain/animation/scene.cpp stopmotion-0.6.2/src/domain/animation/scene.cpp
---- stopmotion-0.6.2.orig/src/domain/animation/scene.cpp 2008-07-25 06:59:03.000000000 -0400
-+++ stopmotion-0.6.2/src/domain/animation/scene.cpp 2012-09-04 08:53:30.841727919 -0400
-@@ -20,6 +20,7 @@
- #include "scene.h"
- #include <sstream>
- #include <cstring>
-+#include <unistd.h>
-
- Scene::Scene()
- {
-diff -aur stopmotion-0.6.2.orig/src/presentation/frontends/qtfrontend/mainwindowgui.cpp stopmotion-0.6.2/src/presentation/frontends/qtfrontend/mainwindowgui.cpp
---- stopmotion-0.6.2.orig/src/presentation/frontends/qtfrontend/mainwindowgui.cpp 2008-07-25 06:59:03.000000000 -0400
-+++ stopmotion-0.6.2/src/presentation/frontends/qtfrontend/mainwindowgui.cpp 2012-09-04 08:53:30.951727867 -0400
-@@ -45,6 +45,7 @@
-
- #include <cstdlib>
- #include <iostream>
-+#include <unistd.h>
-
- using namespace std;
- using namespace Qt;
-diff -aur stopmotion-0.6.2.orig/src/technical/projectserializer.cpp stopmotion-0.6.2/src/technical/projectserializer.cpp
---- stopmotion-0.6.2.orig/src/technical/projectserializer.cpp 2008-07-25 06:59:03.000000000 -0400
-+++ stopmotion-0.6.2/src/technical/projectserializer.cpp 2012-09-04 08:53:31.068394471 -0400
-@@ -28,6 +28,7 @@
- #include <libgen.h>
- #include <stdlib.h>
- #include <cstring>
-+#include <unistd.h>
-
- const char ProjectSerializer::imageDirectory[] = "images/";
- const char ProjectSerializer::soundDirectory[] = "sounds/";
diff --git a/add-x11-lib.patch b/add-x11-lib.patch
deleted file mode 100644
index 7c4635fc0f22..000000000000
--- a/add-x11-lib.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -aur stopmotion-0.6.2/stopmotion.pro.in stopmotion-0.6.2-patched/stopmotion.pro.in
---- stopmotion-0.6.2/stopmotion.pro.in 2008-07-25 06:59:02.000000000 -0400
-+++ stopmotion-0.6.2-patched/stopmotion.pro.in 2012-01-04 11:28:22.000000000 -0500
-@@ -213,6 +213,7 @@
-
- LIBS += $$system(sdl-config --libs) \
- $$system(xml2-config --libs) \
-+ -lX11 \
- -lSDL_image -ltar -lvorbisfile -linotifytools
-
- DISTFILES += src/config.cpp.in \