summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Grimes2012-01-04 10:56:15 -0500
committerMark Grimes2012-01-04 10:56:15 -0500
commitddcea101a084e6d70d787a91e77ed4fb105fce2a (patch)
tree9db6e7a82084971a1a8683c4e0a0b3e05e7ddaa8
downloadaur-ddcea101a084e6d70d787a91e77ed4fb105fce2a.tar.gz
As released 0.6.2-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ae610a54e75
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = stopmotion
+ pkgdesc = Stop motion animation creation program
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = http://stopmotion.bjoernen.com
+ arch = i686
+ license = GPL
+ makedepends = pkgconfig
+ depends = qt
+ depends = libtar
+ depends = sdl_image
+ depends = libxml2
+ depends = libvorbis
+ depends = fam
+ depends = inotify-tools
+ source = http://developer.skolelinux.no/info/studentgrupper/2005-hig-stopmotion/project_management/webpage/releases/stopmotion-0.6.2.tar.gz
+ md5sums = a139f036286f31bba21effb2b6553d1e
+
+pkgname = stopmotion
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aee9851f67b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Mark Grimes <mark_aur@peculier.com>
+
+pkgname=stopmotion
+pkgver=0.6.2
+pkgrel=1
+arch=('i686')
+pkgdesc="Stop motion animation creation program"
+url="http://stopmotion.bjoernen.com"
+license=('GPL')
+# conflicts=()
+# replaces=()
+makedepends=('pkgconfig')
+depends=('qt' 'libtar' 'sdl_image' 'libxml2' 'libvorbis' 'fam' 'inotify-tools')
+source=(http://developer.skolelinux.no/info/studentgrupper/2005-hig-stopmotion/project_management/webpage/releases/$pkgname-$pkgver.tar.gz)
+md5sums=('a139f036286f31bba21effb2b6553d1e')
+
+_qt4profile=/etc/profile.d/qt4.sh
+
+build() {
+ [ -e $_qt4profile ] && . $_qt4profile
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr --with-html-dir=/usr/share/$pkgname/html
+ make || return 1
+ make prefix=$startdir/pkg install
+
+ # Makefile doesn't seem to install the man file
+ gzip ${pkgname}.1
+ mkdir -p $startdir/pkg/usr/share/man/man1 || return 1
+ install -m 644 -p ${pkgname}.1.gz $startdir/pkg/usr/share/man/man1
+}
+