summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2015-08-29 15:45:07 -0400
committerbrent s2015-08-29 15:45:07 -0400
commit8fa2a9925ffc59b55ab02f54ebb4ed8c6ead38a2 (patch)
treef8f2a6d50c95313dee5f72b78e9038d923b098fd
downloadaur-8fa2a9925ffc59b55ab02f54ebb4ed8c6ead38a2.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD38
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..453a07a213ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = storcli
+ pkgdesc = A successor to lsiutil
+ pkgver = 1.15.12
+ pkgrel = 1
+ url = https://www.thomas-krenn.com/en/wiki/StorCLI
+ arch = i686
+ arch = x86_64
+ license = unknown
+ provides = storcli
+ conflicts = megaraid-cli
+ source = http://archive.thomas-krenn.com/packages/pool/optional/s/storcli/storcli_1.15.12_.deb
+
+pkgname = storcli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9165d15c57e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Brent Saner <brent (dot) saner (at) gmail (dot) com>
+
+pkgname=storcli
+pkgver=1.15.12
+pkgrel=1
+pkgdesc="A successor to lsiutil"
+arch=('i686' 'x86_64')
+url="https://www.thomas-krenn.com/en/wiki/StorCLI"
+license=('unknown')
+if [[ "${CARCH}" == 'x86_64' ]];
+then
+ _arch='amd64'
+ _bits='64'
+elif [[ "${CARCH}" == 'i686' ]];
+then
+ _arch='i386'
+ _bits=''
+fi
+source=("http://archive.thomas-krenn.com/packages/pool/optional/s/storcli/storcli_${pkgver}_${_arch}.deb")
+if [[ "${_arch}" == "amd64" ]];
+then
+ md5sums=('a899d70f8f8d106db70c7188a9edeae7')
+elif [[ "${_arch}" == "i386" ]];
+then
+ md5sums=('031e910733b7861749d27968a7d452de')
+fi
+provides=('storcli')
+conflicts=('megaraid-cli')
+
+package() {
+ cd ${srcdir}
+ ar x ${pkgname}_${pkgver}_${_arch}.deb
+ tar -zxf data.tar.gz
+
+ install -D -m755 "${srcdir}/usr/sbin/storcli${_bits}" "${pkgdir}/usr/bin/storcli"
+
+}
+