summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Manna2016-02-01 05:53:50 -0800
committerKyle Manna2016-02-01 05:53:50 -0800
commit0290819280bc5c6ba3e7af590f64082624548b38 (patch)
tree36b23837813fbf7143eb5c8f19cd8bd2552137cf
parent63f8caa74a29776e836aec5f544c8a09991abcbf (diff)
downloadaur-storj-dataserv-client.tar.gz
pkgrel: storj-dataserv-client v2.1.4-3
* Fix test directory clean-up * Correct the setuptools dependency
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc3849b011c0..f35cf0dc029d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
+# Generated by mksrcinfo v8
+# Mon Feb 1 13:53:40 UTC 2016
pkgbase = storj-dataserv-client
pkgdesc = Storj Client for storing and auditing data
pkgver = 2.1.4
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/Storj/dataserv-client
arch = any
license = MIT
depends = python
- depends = python-pip
+ depends = python-setuptools
depends = python-future
depends = python-randomio
depends = python-partialhash
@@ -14,7 +16,7 @@ pkgbase = storj-dataserv-client
depends = python-psutil
depends = python-storjcore
source = https://github.com/Storj/dataserv-client/archive/v2.1.4.tar.gz
- sha256sums = d28dba786e3c18c2bcf3448b79f316ba51103029d9bf3927a342bb777f561691
+ sha512sums = b7bc917fc4434a978835b0dc99edac423d3f65ba91176a95f64a1651bc27ea7faa2d2d568bfe6f7bb5cbb13ee80fd6db85dd02376a483ee03cddc712931aa4e8
pkgname = storj-dataserv-client
diff --git a/PKGBUILD b/PKGBUILD
index 6e3292c9c2dd..c45c89369315 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
pkgname=storj-dataserv-client
_pkgname=${pkgname/storj-/}
pkgver=2.1.4
-pkgrel=2
+pkgrel=3
pkgdesc="Storj Client for storing and auditing data"
url="https://github.com/Storj/dataserv-client"
-depends=('python' 'python-pip' 'python-future' 'python-randomio' 'python-partialhash' 'python-btctxstore' 'python-psutil' 'python-storjcore')
+depends=('python' 'python-setuptools' 'python-future' 'python-randomio' 'python-partialhash' 'python-btctxstore' 'python-psutil' 'python-storjcore')
optdepends=()
license=('MIT')
arch=('any')
source=("https://github.com/Storj/${_pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('d28dba786e3c18c2bcf3448b79f316ba51103029d9bf3927a342bb777f561691')
+sha512sums=('b7bc917fc4434a978835b0dc99edac423d3f65ba91176a95f64a1651bc27ea7faa2d2d568bfe6f7bb5cbb13ee80fd6db85dd02376a483ee03cddc712931aa4e8')
build() {
cd "$srcdir/$_pkgname-$pkgver"
@@ -20,6 +20,6 @@ build() {
package() {
cd "$srcdir/$_pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
- rm -rf ${pkgdir}/usr/lib/python3.4/site-packages/tests/
+ rm -rf ${pkgdir}/usr/lib/python*/site-packages/tests/
}