summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSascha Wunderlich2017-08-04 15:28:42 +0200
committerSascha Wunderlich2017-08-04 15:28:42 +0200
commit843dd09d1256fe0ca614a38558320e9273eb4043 (patch)
treefed1f59e013e13c4b118a1fea12e56caa4d14407
downloadaur-843dd09d1256fe0ca614a38558320e9273eb4043.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD47
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10217809c54b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = stormchecker-git
+ pkgdesc = Storm is a tool for the analysis of systems involving random or probabilistic phenomena
+ pkgver = 1.0.1.r247.g3f241280e
+ pkgrel = 1
+ url = http://www.stormchecker.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ depends = glpk
+ depends = hwloc
+ depends = xerces-c
+ depends = z3
+ depends = carl-git
+ provides = stormchecker
+ conflicts = stormchecker
+ source = stormchecker-git::git+https://github.com/moves-rwth/storm.git
+ md5sums = SKIP
+
+pkgname = stormchecker-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c4cf3addb05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Sascha Wunderlich <archlinux at saschawunderlich dot de>
+pkgname=stormchecker-git
+pkgver=1.0.1.r247.g3f241280e
+pkgrel=1
+pkgdesc="Storm is a tool for the analysis of systems involving random or probabilistic phenomena"
+arch=(i686 x86_64)
+url="http://www.stormchecker.org/"
+license=('GPL3')
+groups=()
+conflicts=('stormchecker')
+provides=('stormchecker')
+# TODO: mathsat?
+# TODO: sylvan is always shipped at the moment
+# TODO: carl-git hides some dependencies here
+depends=(glpk hwloc xerces-c z3 carl-git)
+makedepends=(git cmake)
+source=("stormchecker-git::git+https://github.com/moves-rwth/storm.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ rm -rf build/
+
+ mkdir build
+ cd build
+
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib \
+ ..
+
+ make
+}
+
+#check() {
+# cd "$pkgname"/build
+# make check
+#}
+
+package() {
+ cd "$pkgname"/build
+ make DESTDIR="$pkgdir/" install/fast
+}