summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsomeoneonsmile2022-05-17 19:34:47 +0800
committersomeoneonsmile2022-05-17 19:34:47 +0800
commit353045ebe20d6944fa415ffdb29275c9364c120c (patch)
tree889b5130cc7dbb7c135168ddd1b8f914d01ba6b5
parentd689d76b970ab7bf33d2677af64462c9fac03a46 (diff)
downloadaur-353045ebe20d6944fa415ffdb29275c9364c120c.tar.gz
replace with bin
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD16
2 files changed, 6 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 618ff94403d5..d521feb7306c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,10 +5,9 @@ pkgbase = stow-cm
url = https://github.com/someoneonsmile/stow
arch = x86_64
license = GPL2
- makedepends = cargo
depends = gcc-libs
conflicts = stow
- source = stow-cm::git+https://github.com/someoneonsmile/stow.git
+ source = stow-cm.tar.gz::https://github.com/someoneonsmile/stow/releases/download/nightly/stow-nightly-x86_64-unknown-linux-musl.tar.gz
sha512sums = SKIP
pkgname = stow-cm
diff --git a/PKGBUILD b/PKGBUILD
index 3c07f2c3d320..3cfb7e91ca0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,23 +7,17 @@ arch=('x86_64')
url="https://github.com/someoneonsmile/stow"
license=('GPL2')
depends=('gcc-libs')
-makedepends=('cargo')
+makedepends=()
conflicts=('stow')
-source=("${pkgname}::git+https://github.com/someoneonsmile/stow.git")
+source=("${pkgname}.tar.gz::https://github.com/someoneonsmile/stow/releases/download/nightly/stow-nightly-x86_64-unknown-linux-musl.tar.gz")
sha512sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname}"
- printf "nightly-%s.%s" "$(git rev-list --count nightly)" "$(git rev-parse --short nightly)"
-}
-
-build() {
- cd "stow-$pkgver"
- cargo build --release
+ printf "nightly"
}
package() {
cd "stow-$pkgver"
- install -Dm755 "target/release/stow" "$pkgdir/usr/bin/stow"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 "*/stow" "$pkgdir/usr/bin/stow-cm"
+ install -Dm644 "*/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}