summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsomeoneonsmile2022-05-22 01:08:02 +0800
committersomeoneonsmile2022-05-22 01:08:02 +0800
commit3c853fd9a8c726ee4e6c908dc226ac6f0f2fb42b (patch)
tree2ee5b79a639c21f4c1c60403ba6455a39f20ebf8
parent353045ebe20d6944fa415ffdb29275c9364c120c (diff)
downloadaur-3c853fd9a8c726ee4e6c908dc226ac6f0f2fb42b.tar.gz
fix
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d521feb7306c..e9b755c0b917 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,7 @@ pkgbase = stow-cm
license = GPL2
depends = gcc-libs
conflicts = stow
- source = stow-cm.tar.gz::https://github.com/someoneonsmile/stow/releases/download/nightly/stow-nightly-x86_64-unknown-linux-musl.tar.gz
+ source = stow-cm.tar.gz::https://github.com/someoneonsmile/stow/releases/download/nightly/stow-x86_64-unknown-linux-musl.tar.gz
sha512sums = SKIP
pkgname = stow-cm
diff --git a/PKGBUILD b/PKGBUILD
index 3cfb7e91ca0c..419e324f2547 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ license=('GPL2')
depends=('gcc-libs')
makedepends=()
conflicts=('stow')
-source=("${pkgname}.tar.gz::https://github.com/someoneonsmile/stow/releases/download/nightly/stow-nightly-x86_64-unknown-linux-musl.tar.gz")
+source=("${pkgname}.tar.gz::https://github.com/someoneonsmile/stow/releases/download/${pkgver}/stow-x86_64-unknown-linux-musl.tar.gz")
sha512sums=('SKIP')
pkgver() {
@@ -17,7 +17,7 @@ pkgver() {
}
package() {
- cd "stow-$pkgver"
- install -Dm755 "*/stow" "$pkgdir/usr/bin/stow-cm"
- install -Dm644 "*/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$srcdir/stow-x86_64-unknown-linux-musl"
+ install -Dm755 "stow" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}